Wasp.Cloud.Asset.Example Namespace

Classes
 | Class | Description
Public class | CSharpPublicApiExampleProgram |
Public class | CSharpPublicApiExampleProgramAssetsPublicApiClientLongTimeout |
Public class | CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel |
Public class | CSharpPublicApiExampleProgramAttachmentUploadAttributes |
Public class | CSharpPublicApiExampleProgramPurchaseOrderColumnOrder |
Public class | CSharpPublicApiExampleProgramTConverter |
Public class | Filter |
Public class | SortCollection |
Enumerations
 | Enumeration | Description
Public enumeration | CSharpPublicApiExampleProgramUploadFileType |
Public enumeration | CSharpPublicApiExampleProgramWtFormId |


CSharpPublicApiExampleProgram Class

Inheritance Hierarchy
SystemObject
Wasp.Cloud.Asset.ExampleCSharpPublicApiExampleProgram

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public class CSharpPublicApiExampleProgram
Public Class CSharpPublicApiExampleProgram
public ref class CSharpPublicApiExampleProgram
type CSharpPublicApiExampleProgram = class end
public class CSharpPublicApiExampleProgram
Wasp.Cloud.Asset.Example.CSharpPublicApiExampleProgram = function();

Type.createClass(
    'Wasp.Cloud.Asset.Example.CSharpPublicApiExampleProgram');

The CSharpPublicApiExampleProgram type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpPublicApiExampleProgram | Initializes a new instance of the CSharpPublicApiExampleProgram class
Top
Methods
 | Name | Description
Public method | AC_UploadAttachmentForDifferentFormsSample |
Public method | AdvancedInfoSearchSiteFiltering |
 | AssertFalse |
 | AssertTrue |
Public method | AssetTransactionHistory |
Private method | AssetTransactionHistorySample |
Private method | AssetTypeAdvancedInfoSearch |
Private method | AssetTypeInfoSearch |
Public method | AssetTypeLifeCycle |
Private method | AutomatedUploadSample |
Private method | AutoUploadPurchaseOrders |
Private method | AutoUploadSites |
Public method | CalloutSignatureCalculated |
Public method | CheckForDemoDataAsync |
Public method | CheckForEmptyDatabaseAsync |
Private method | CheckInSample |
Private method | CheckOutSample |
 | ComputeSHA256Hash |
Public method | CreateAndUpdateFixedAssetWithAttachmentGUID |
Private method | CreateEmploySample |
Private method | CreatePurchaseOrderAsync |
Private method | CreatePurchaseOrderFailureSample |
Public method | CreatePurchaseOrderSample |
Public method | CreateSitesWithDcfAndQueryFilterByCustomFields |
Private method | CustomersSample |
Private method | DeleteCustomersSample |
Public method | DemoAssetLife |
Private method | DemoAssetLifeCycle |
Private method | DemoAuditCount |
Public method | DemoAuditCountExample |
Private method | DemoCreateUpdateContracts |
Public method | DemoCreateUpdateContractsLatest |
Private method | DemoCreateUpdateFundings |
Private method | DemoGetAssetTypes |
Private method | DepartmentSpamCreateUntilServerThrottled |
Private method | DisposeSample |
Public method | DownloadAttachment |
Private method | EmployeeSpamCreateUntilServerThrottled |
Public method | EmployeeSpamCreateUntilServerThrottledLatest |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | ExactSearchSite |
Public method | ExamplesThatRequireOnlyReadAccess |
Public method | ExamplesThatRequireWriteAccess |
Private method | FetchAssetInfoWithExplicitAssetTags |
Private method | FetchAssetInfoWithOwnerNumberFiltering |
Public method | FetchTransactionHistoryInfoUsingGridQuery |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GenerateHelpExamples |
Public method | GetCalloutHeaderPrivateKeyHash |
Private method | GetDepartmentTests |
Private method | GetEmployeeTests |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetServerInfo |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetValueT |
Private method | ImportAttachmentsFromCSVFileToWaspApplication |
Private method | ImportAttachmentsFromLargeCSVFileToWaspApplication |
 | Main |
Private method | ManufacturersSample |
Private method | MassReadLine |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Private method | NewAssetType |
Public method | ParseHex |
 | ParseNybble |
Public method | RunAllExamples |
Private method | RunSitesLocationsDemo |
Private method | SaveCustomerTest |
Private method | SaveEmployeeTest |
Public method | SearchAsset |
Private method | SimpleCreateReadUpdateDeleteLocationSample |
Public method | SimpleCreateReadUpdateDeleteSearchLocation |
Public method | SimpleCreateReadUpdateDeleteSearchSite |
Private method | SimpleCreateReadUpdateDeleteSiteSample |
Private method | SiteCustomFieldSample |
Private method | SiteModelInfoAdvancedSearch |
Private method | SiteModelInfoAdvancedSearchAsRawJsonDataStrings |
Private method | StreamInventoryAdvanced |
Private method | SuppliersSample |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Private method | TransactionMove_GetHistoryNotesSample |
Private method | UpdateAssetType |
Private method | UpdateCustomersSample |
Private method | UpdateManufacturersSample |
Public method | UpdatePurchaseOrderSample |
Private method | UpdateSuppliersSample |
Private method | UploadAttachmentForDifferentFormsSample |
Public method | UploadAttachmentOnServer |
Private method | UploadAttachmentOnServerSample |
Private method | UploadFile |
Private method | UploadFileLatest |
Top
Fields
 | Name | Description
Private field | _guidString |
Private field | _initializer |
Private field | charBuffer |
 | DCF_SHIPMENT_NOT_RECEIVED |
 | DCF_SHIPMENT_SHIPPED |
Top
See Also

Reference

Wasp.Cloud.Asset.Example Namespace


CSharpPublicApiExampleProgram Constructor

Initializes a new instance of the CSharpPublicApiExampleProgram class

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public CSharpPublicApiExampleProgram()
Public Sub New
public:
CSharpPublicApiExampleProgram()
new : unit -> CSharpPublicApiExampleProgram
public CSharpPublicApiExampleProgram()
Wasp.Cloud.Asset.Example.CSharpPublicApiExampleProgram = function();
See Also

Reference

CSharpPublicApiExampleProgram Class


CSharpPublicApiExampleProgram Methods

The CSharpPublicApiExampleProgram type exposes the following members.

Methods
 | Name | Description
Public method | AC_UploadAttachmentForDifferentFormsSample |
Public method | AdvancedInfoSearchSiteFiltering |
 | AssertFalse |
 | AssertTrue |
Public method | AssetTransactionHistory |
Private method | AssetTransactionHistorySample |
Private method | AssetTypeAdvancedInfoSearch |
Private method | AssetTypeInfoSearch |
Public method | AssetTypeLifeCycle |
Private method | AutomatedUploadSample |
Private method | AutoUploadPurchaseOrders |
Private method | AutoUploadSites |
Public method | CalloutSignatureCalculated |
Public method | CheckForDemoDataAsync |
Public method | CheckForEmptyDatabaseAsync |
Private method | CheckInSample |
Private method | CheckOutSample |
 | ComputeSHA256Hash |
Public method | CreateAndUpdateFixedAssetWithAttachmentGUID |
Private method | CreateEmploySample |
Private method | CreatePurchaseOrderAsync |
Private method | CreatePurchaseOrderFailureSample |
Public method | CreatePurchaseOrderSample |
Public method | CreateSitesWithDcfAndQueryFilterByCustomFields |
Private method | CustomersSample |
Private method | DeleteCustomersSample |
Public method | DemoAssetLife |
Private method | DemoAssetLifeCycle |
Private method | DemoAuditCount |
Public method | DemoAuditCountExample |
Private method | DemoCreateUpdateContracts |
Public method | DemoCreateUpdateContractsLatest |
Private method | DemoCreateUpdateFundings |
Private method | DemoGetAssetTypes |
Private method | DepartmentSpamCreateUntilServerThrottled |
Private method | DisposeSample |
Public method | DownloadAttachment |
Private method | EmployeeSpamCreateUntilServerThrottled |
Public method | EmployeeSpamCreateUntilServerThrottledLatest |
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
 | ExactSearchSite |
Public method | ExamplesThatRequireOnlyReadAccess |
Public method | ExamplesThatRequireWriteAccess |
Private method | FetchAssetInfoWithExplicitAssetTags |
Private method | FetchAssetInfoWithOwnerNumberFiltering |
Public method | FetchTransactionHistoryInfoUsingGridQuery |
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GenerateHelpExamples |
Public method | GetCalloutHeaderPrivateKeyHash |
Private method | GetDepartmentTests |
Private method | GetEmployeeTests |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetServerInfo |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | GetValueT |
Private method | ImportAttachmentsFromCSVFileToWaspApplication |
Private method | ImportAttachmentsFromLargeCSVFileToWaspApplication |
 | Main |
Private method | ManufacturersSample |
Private method | MassReadLine |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Private method | NewAssetType |
Public method | ParseHex |
 | ParseNybble |
Public method | RunAllExamples |
Private method | RunSitesLocationsDemo |
Private method | SaveCustomerTest |
Private method | SaveEmployeeTest |
Public method | SearchAsset |
Private method | SimpleCreateReadUpdateDeleteLocationSample |
Public method | SimpleCreateReadUpdateDeleteSearchLocation |
Public method | SimpleCreateReadUpdateDeleteSearchSite |
Private method | SimpleCreateReadUpdateDeleteSiteSample |
Private method | SiteCustomFieldSample |
Private method | SiteModelInfoAdvancedSearch |
Private method | SiteModelInfoAdvancedSearchAsRawJsonDataStrings |
Private method | StreamInventoryAdvanced |
Private method | SuppliersSample |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Private method | TransactionMove_GetHistoryNotesSample |
Private method | UpdateAssetType |
Private method | UpdateCustomersSample |
Private method | UpdateManufacturersSample |
Public method | UpdatePurchaseOrderSample |
Private method | UpdateSuppliersSample |
Private method | UploadAttachmentForDifferentFormsSample |
Public method | UploadAttachmentOnServer |
Private method | UploadAttachmentOnServerSample |
Private method | UploadFile |
Private method | UploadFileLatest |
Top
See Also

Reference


CSharpPublicApiExampleProgram.AC_UploadAttachmentForDifferentFormsSample Method

A Sandcastle Documented Class Library

CSharpPublicApiExampleProgramAC_UploadAttachmentForDifferentFormsSample Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> AC_UploadAttachmentForDifferentFormsSample()
Public Function AC_UploadAttachmentForDifferentFormsSample As Task(Of Integer)
public:
Task<int>^ AC_UploadAttachmentForDifferentFormsSample()
member AC_UploadAttachmentForDifferentFormsSample : unit -> Task<int>
public Task<int> AC_UploadAttachmentForDifferentFormsSample()
function AC_UploadAttachmentForDifferentFormsSample();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.AdvancedInfoSearchSiteFiltering Method

CSharpPublicApiExampleProgramAdvancedInfoSearchSiteFiltering Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> AdvancedInfoSearchSiteFiltering()
Public Function AdvancedInfoSearchSiteFiltering As Task(Of Integer)
public:
Task<int>^ AdvancedInfoSearchSiteFiltering()
member AdvancedInfoSearchSiteFiltering : unit -> Task<int>
public Task<int> AdvancedInfoSearchSiteFiltering()
function AdvancedInfoSearchSiteFiltering();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.AssertFalse Method

CSharpPublicApiExampleProgramAssertFalse Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private static void AssertFalse(
    bool flag,
    string msg = null
)
Private Shared Sub AssertFalse (
    flag As Boolean,
    Optional msg As String = Nothing
)
private:
static void AssertFalse(
    bool flag,
    String^ msg = nullptr
)
private static member AssertFalse :
        flag : bool *
        ?msg : string
(* Defaults:
        let _msg = defaultArg msg null
*)
-> unit
private static void AssertFalse(
    boolean flag,
    String msg = null
)
Wasp.Cloud.Asset.Example.CSharpPublicApiExampleProgram.AssertFalse = function(flag, msg);

Parameters

flag Boolean
msg String (Optional)
See Also

Reference


CSharpPublicApiExampleProgram.AssertTrue Method

CSharpPublicApiExampleProgramAssertTrue Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private static void AssertTrue(
    bool flag,
    string msg = null
)
Private Shared Sub AssertTrue (
    flag As Boolean,
    Optional msg As String = Nothing
)
private:
static void AssertTrue(
    bool flag,
    String^ msg = nullptr
)
private static member AssertTrue :
        flag : bool *
        ?msg : string
(* Defaults:
        let _msg = defaultArg msg null
*)
-> unit
private static void AssertTrue(
    boolean flag,
    String msg = null
)
Wasp.Cloud.Asset.Example.CSharpPublicApiExampleProgram.AssertTrue = function(flag, msg);

Parameters

flag Boolean
msg String (Optional)
See Also

Reference


CSharpPublicApiExampleProgram.AssetTransactionHistory Method

CSharpPublicApiExampleProgramAssetTransactionHistory Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> AssetTransactionHistory(
    string assetTag = "98765057"
)
Public Function AssetTransactionHistory (
    Optional assetTag As String = "98765057"
) As Task(Of Integer)
public:
Task<int>^ AssetTransactionHistory(
    String^ assetTag = L"98765057"
)
member AssetTransactionHistory :
        ?assetTag : string
(* Defaults:
        let _assetTag = defaultArg assetTag "98765057"
*)
-> Task<int>
public Task<int> AssetTransactionHistory(
    String assetTag = "98765057"
)
function AssetTransactionHistory(assetTag);

Parameters

assetTag String (Optional)

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.AssetTransactionHistorySample Method

CSharpPublicApiExampleProgramAssetTransactionHistorySample Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> AssetTransactionHistorySample(
    string assetTag = "98765057"
)
Private Function AssetTransactionHistorySample (
    Optional assetTag As String = "98765057"
) As Task(Of Integer)
private:
Task<int>^ AssetTransactionHistorySample(
    String^ assetTag = L"98765057"
)
private member AssetTransactionHistorySample :
        ?assetTag : string
(* Defaults:
        let _assetTag = defaultArg assetTag "98765057"
*)
-> Task<int>
private Task<int> AssetTransactionHistorySample(
    String assetTag = "98765057"
)
function AssetTransactionHistorySample(assetTag);

Parameters

assetTag String (Optional)

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.AssetTypeAdvancedInfoSearch Method

CSharpPublicApiExampleProgramAssetTypeAdvancedInfoSearch Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> AssetTypeAdvancedInfoSearch()
Private Function AssetTypeAdvancedInfoSearch As Task(Of Integer)
private:
Task<int>^ AssetTypeAdvancedInfoSearch()
private member AssetTypeAdvancedInfoSearch : unit -> Task<int>
private Task<int> AssetTypeAdvancedInfoSearch()
function AssetTypeAdvancedInfoSearch();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.AssetTypeInfoSearch Method

CSharpPublicApiExampleProgramAssetTypeInfoSearch Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> AssetTypeInfoSearch()
Private Function AssetTypeInfoSearch As Task(Of Integer)
private:
Task<int>^ AssetTypeInfoSearch()
private member AssetTypeInfoSearch : unit -> Task<int>
private Task<int> AssetTypeInfoSearch()
function AssetTypeInfoSearch();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.AssetTypeLifeCycle Method

CSharpPublicApiExampleProgramAssetTypeLifeCycle Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> AssetTypeLifeCycle()
Public Function AssetTypeLifeCycle As Task(Of Integer)
public:
Task<int>^ AssetTypeLifeCycle()
member AssetTypeLifeCycle : unit -> Task<int>
public Task<int> AssetTypeLifeCycle()
function AssetTypeLifeCycle();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.AutomatedUploadSample Method

CSharpPublicApiExampleProgramAutomatedUploadSample Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> AutomatedUploadSample()
Private Function AutomatedUploadSample As Task(Of Integer)
private:
Task<int>^ AutomatedUploadSample()
private member AutomatedUploadSample : unit -> Task<int>
private Task<int> AutomatedUploadSample()
function AutomatedUploadSample();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.AutoUploadPurchaseOrders Method

CSharpPublicApiExampleProgramAutoUploadPurchaseOrders Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> AutoUploadPurchaseOrders(
    string fileName
)
Private Function AutoUploadPurchaseOrders (
    fileName As String
) As Task(Of Integer)
private:
Task<int>^ AutoUploadPurchaseOrders(
    String^ fileName
)
private member AutoUploadPurchaseOrders :
        fileName : string -> Task<int>
private Task<int> AutoUploadPurchaseOrders(
    String fileName
)
function AutoUploadPurchaseOrders(fileName);

Parameters

fileName String

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.AutoUploadSites Method

CSharpPublicApiExampleProgramAutoUploadSites Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> AutoUploadSites(
    string fileName
)
Private Function AutoUploadSites (
    fileName As String
) As Task(Of Integer)
private:
Task<int>^ AutoUploadSites(
    String^ fileName
)
private member AutoUploadSites :
        fileName : string -> Task<int>
private Task<int> AutoUploadSites(
    String fileName
)
function AutoUploadSites(fileName);

Parameters

fileName String

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.CalloutSignatureCalculated Method

CSharpPublicApiExampleProgramCalloutSignatureCalculated Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string CalloutSignatureCalculated(
    string Wasp_Callout_Name,
    string Wasp_Callout_Timestamp
)
Public Function CalloutSignatureCalculated (
    Wasp_Callout_Name As String,
    Wasp_Callout_Timestamp As String
) As String
public:
String^ CalloutSignatureCalculated(
    String^ Wasp_Callout_Name,
    String^ Wasp_Callout_Timestamp
)
member CalloutSignatureCalculated :
        Wasp_Callout_Name : string *
        Wasp_Callout_Timestamp : string -> string
public String CalloutSignatureCalculated(
    String Wasp_Callout_Name,
    String Wasp_Callout_Timestamp
)
function CalloutSignatureCalculated(Wasp_Callout_Name, Wasp_Callout_Timestamp);

Parameters

Wasp_Callout_Name String
Wasp_Callout_Timestamp String

Return Value

String
See Also

Reference


CSharpPublicApiExampleProgram.CheckForDemoDataAsync Method

CSharpPublicApiExampleProgramCheckForDemoDataAsync Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<bool> CheckForDemoDataAsync()
Public Function CheckForDemoDataAsync As Task(Of Boolean)
public:
Task<bool>^ CheckForDemoDataAsync()
member CheckForDemoDataAsync : unit -> Task<bool>
public Task<boolean> CheckForDemoDataAsync()
function CheckForDemoDataAsync();

Return Value

Task Boolean
See Also

Reference


CSharpPublicApiExampleProgram.CheckForEmptyDatabaseAsync Method

CSharpPublicApiExampleProgramCheckForEmptyDatabaseAsync Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<bool> CheckForEmptyDatabaseAsync()
Public Function CheckForEmptyDatabaseAsync As Task(Of Boolean)
public:
Task<bool>^ CheckForEmptyDatabaseAsync()
member CheckForEmptyDatabaseAsync : unit -> Task<bool>
public Task<boolean> CheckForEmptyDatabaseAsync()
function CheckForEmptyDatabaseAsync();

Return Value

Task Boolean
See Also

Reference


CSharpPublicApiExampleProgram.CheckInSample Method

CSharpPublicApiExampleProgramCheckInSample Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> CheckInSample()
Private Function CheckInSample As Task(Of Integer)
private:
Task<int>^ CheckInSample()
private member CheckInSample : unit -> Task<int>
private Task<int> CheckInSample()
function CheckInSample();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.CheckOutSample Method

CSharpPublicApiExampleProgramCheckOutSample Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> CheckOutSample()
Private Function CheckOutSample As Task(Of Integer)
private:
Task<int>^ CheckOutSample()
private member CheckOutSample : unit -> Task<int>
private Task<int> CheckOutSample()
function CheckOutSample();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.ComputeSHA256Hash Method

CSharpPublicApiExampleProgramComputeSHA256Hash Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private static byte[] ComputeSHA256Hash(
    Encoding encoding,
    string secret,
    params string[] texts
)
Private Shared Function ComputeSHA256Hash (
    encoding As Encoding,
    secret As String,
    ParamArray texts As String()
) As Byte()
private:
static array<unsigned char>^ ComputeSHA256Hash(
    Encoding^ encoding,
    String^ secret,
    ... array<String^>^ texts
)
private static member ComputeSHA256Hash :
        encoding : Encoding *
        secret : string *
        texts : string[] -> byte[]
private static byte[] ComputeSHA256Hash(
    Encoding encoding,
    String secret,
    String[] texts
)
Wasp.Cloud.Asset.Example.CSharpPublicApiExampleProgram.ComputeSHA256Hash = function(encoding, secret, ... texts);

Parameters

encoding Encoding
secret String
texts String

Return Value

Byte
See Also

Reference


CSharpPublicApiExampleProgram.CreateAndUpdateFixedAssetWithAttachmentGUID Method

CSharpPublicApiExampleProgramCreateAndUpdateFixedAssetWithAttachmentGUID Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task CreateAndUpdateFixedAssetWithAttachmentGUID()
Public Function CreateAndUpdateFixedAssetWithAttachmentGUID As Task
public:
Task^ CreateAndUpdateFixedAssetWithAttachmentGUID()
member CreateAndUpdateFixedAssetWithAttachmentGUID : unit -> Task
public Task CreateAndUpdateFixedAssetWithAttachmentGUID()
function CreateAndUpdateFixedAssetWithAttachmentGUID();

Return Value

Task
See Also

Reference


CSharpPublicApiExampleProgram.CreateEmploySample Method

CSharpPublicApiExampleProgramCreateEmploySample Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> CreateEmploySample()
Private Function CreateEmploySample As Task(Of Integer)
private:
Task<int>^ CreateEmploySample()
private member CreateEmploySample : unit -> Task<int>
private Task<int> CreateEmploySample()
function CreateEmploySample();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.CreatePurchaseOrderAsync Method

CSharpPublicApiExampleProgramCreatePurchaseOrderAsync Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<AssetPurchaseOrderInfo> CreatePurchaseOrderAsync()
Private Function CreatePurchaseOrderAsync As Task(Of AssetPurchaseOrderInfo)
private:
Task<AssetPurchaseOrderInfo^>^ CreatePurchaseOrderAsync()
private member CreatePurchaseOrderAsync : unit -> Task<AssetPurchaseOrderInfo>
private Task<AssetPurchaseOrderInfo> CreatePurchaseOrderAsync()
function CreatePurchaseOrderAsync();

Return Value

Task AssetPurchaseOrderInfo
See Also

Reference


CSharpPublicApiExampleProgram.CreatePurchaseOrderFailureSample Method

CSharpPublicApiExampleProgramCreatePurchaseOrderFailureSample Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> CreatePurchaseOrderFailureSample()
Private Function CreatePurchaseOrderFailureSample As Task(Of Integer)
private:
Task<int>^ CreatePurchaseOrderFailureSample()
private member CreatePurchaseOrderFailureSample : unit -> Task<int>
private Task<int> CreatePurchaseOrderFailureSample()
function CreatePurchaseOrderFailureSample();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.CreatePurchaseOrderSample Method

CSharpPublicApiExampleProgramCreatePurchaseOrderSample Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> CreatePurchaseOrderSample()
Public Function CreatePurchaseOrderSample As Task(Of Integer)
public:
Task<int>^ CreatePurchaseOrderSample()
member CreatePurchaseOrderSample : unit -> Task<int>
public Task<int> CreatePurchaseOrderSample()
function CreatePurchaseOrderSample();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.CreateSitesWithDcfAndQueryFilterByCustomFields Method

CSharpPublicApiExampleProgramCreateSitesWithDcfAndQueryFilterByCustomFields Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> CreateSitesWithDcfAndQueryFilterByCustomFields()
Public Function CreateSitesWithDcfAndQueryFilterByCustomFields As Task(Of Integer)
public:
Task<int>^ CreateSitesWithDcfAndQueryFilterByCustomFields()
member CreateSitesWithDcfAndQueryFilterByCustomFields : unit -> Task<int>
public Task<int> CreateSitesWithDcfAndQueryFilterByCustomFields()
function CreateSitesWithDcfAndQueryFilterByCustomFields();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.CustomersSample Method

CSharpPublicApiExampleProgramCustomersSample Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> CustomersSample()
Private Function CustomersSample As Task(Of Integer)
private:
Task<int>^ CustomersSample()
private member CustomersSample : unit -> Task<int>
private Task<int> CustomersSample()
function CustomersSample();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.DeleteCustomersSample Method

CSharpPublicApiExampleProgramDeleteCustomersSample Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> DeleteCustomersSample()
Private Function DeleteCustomersSample As Task(Of Integer)
private:
Task<int>^ DeleteCustomersSample()
private member DeleteCustomersSample : unit -> Task<int>
private Task<int> DeleteCustomersSample()
function DeleteCustomersSample();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.DemoAssetLife Method

CSharpPublicApiExampleProgramDemoAssetLife Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> DemoAssetLife()
Public Function DemoAssetLife As Task(Of Integer)
public:
Task<int>^ DemoAssetLife()
member DemoAssetLife : unit -> Task<int>
public Task<int> DemoAssetLife()
function DemoAssetLife();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.DemoAssetLifeCycle Method

CSharpPublicApiExampleProgramDemoAssetLifeCycle Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> DemoAssetLifeCycle()
Private Function DemoAssetLifeCycle As Task(Of Integer)
private:
Task<int>^ DemoAssetLifeCycle()
private member DemoAssetLifeCycle : unit -> Task<int>
private Task<int> DemoAssetLifeCycle()
function DemoAssetLifeCycle();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.DemoAuditCount Method

CSharpPublicApiExampleProgramDemoAuditCount Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> DemoAuditCount()
Private Function DemoAuditCount As Task(Of Integer)
private:
Task<int>^ DemoAuditCount()
private member DemoAuditCount : unit -> Task<int>
private Task<int> DemoAuditCount()
function DemoAuditCount();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.DemoAuditCountExample Method

CSharpPublicApiExampleProgramDemoAuditCountExample Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> DemoAuditCountExample()
Public Function DemoAuditCountExample As Task(Of Integer)
public:
Task<int>^ DemoAuditCountExample()
member DemoAuditCountExample : unit -> Task<int>
public Task<int> DemoAuditCountExample()
function DemoAuditCountExample();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.DemoCreateUpdateContracts Method

CSharpPublicApiExampleProgramDemoCreateUpdateContracts Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> DemoCreateUpdateContracts()
Private Function DemoCreateUpdateContracts As Task(Of Integer)
private:
Task<int>^ DemoCreateUpdateContracts()
private member DemoCreateUpdateContracts : unit -> Task<int>
private Task<int> DemoCreateUpdateContracts()
function DemoCreateUpdateContracts();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.DemoCreateUpdateContractsLatest Method

CSharpPublicApiExampleProgramDemoCreateUpdateContractsLatest Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> DemoCreateUpdateContractsLatest()
Public Function DemoCreateUpdateContractsLatest As Task(Of Integer)
public:
Task<int>^ DemoCreateUpdateContractsLatest()
member DemoCreateUpdateContractsLatest : unit -> Task<int>
public Task<int> DemoCreateUpdateContractsLatest()
function DemoCreateUpdateContractsLatest();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.DemoCreateUpdateFundings Method

CSharpPublicApiExampleProgramDemoCreateUpdateFundings Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> DemoCreateUpdateFundings()
Private Function DemoCreateUpdateFundings As Task(Of Integer)
private:
Task<int>^ DemoCreateUpdateFundings()
private member DemoCreateUpdateFundings : unit -> Task<int>
private Task<int> DemoCreateUpdateFundings()
function DemoCreateUpdateFundings();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.DemoGetAssetTypes Method

CSharpPublicApiExampleProgramDemoGetAssetTypes Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> DemoGetAssetTypes()
Private Function DemoGetAssetTypes As Task(Of Integer)
private:
Task<int>^ DemoGetAssetTypes()
private member DemoGetAssetTypes : unit -> Task<int>
private Task<int> DemoGetAssetTypes()
function DemoGetAssetTypes();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.DepartmentSpamCreateUntilServerThrottled Method

CSharpPublicApiExampleProgramDepartmentSpamCreateUntilServerThrottled Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task DepartmentSpamCreateUntilServerThrottled(
    int iterations = 1
)
Private Function DepartmentSpamCreateUntilServerThrottled (
    Optional iterations As Integer = 1
) As Task
private:
Task^ DepartmentSpamCreateUntilServerThrottled(
    int iterations = 1
)
private member DepartmentSpamCreateUntilServerThrottled :
        ?iterations : int
(* Defaults:
        let _iterations = defaultArg iterations 1
*)
-> Task
private Task DepartmentSpamCreateUntilServerThrottled(
    int iterations = 1
)
function DepartmentSpamCreateUntilServerThrottled(iterations);

Parameters

iterations Int32 (Optional)

Return Value

Task
See Also

Reference


CSharpPublicApiExampleProgram.DisposeSample Method

CSharpPublicApiExampleProgramDisposeSample Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> DisposeSample()
Private Function DisposeSample As Task(Of Integer)
private:
Task<int>^ DisposeSample()
private member DisposeSample : unit -> Task<int>
private Task<int> DisposeSample()
function DisposeSample();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.DownloadAttachment Method

CSharpPublicApiExampleProgramDownloadAttachment Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task DownloadAttachment()
Public Function DownloadAttachment As Task
public:
Task^ DownloadAttachment()
member DownloadAttachment : unit -> Task
public Task DownloadAttachment()
function DownloadAttachment();

Return Value

Task
See Also

Reference


CSharpPublicApiExampleProgram.EmployeeSpamCreateUntilServerThrottled Method

CSharpPublicApiExampleProgramEmployeeSpamCreateUntilServerThrottled Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task EmployeeSpamCreateUntilServerThrottled(
    int iterations = 1
)
Private Function EmployeeSpamCreateUntilServerThrottled (
    Optional iterations As Integer = 1
) As Task
private:
Task^ EmployeeSpamCreateUntilServerThrottled(
    int iterations = 1
)
private member EmployeeSpamCreateUntilServerThrottled :
        ?iterations : int
(* Defaults:
        let _iterations = defaultArg iterations 1
*)
-> Task
private Task EmployeeSpamCreateUntilServerThrottled(
    int iterations = 1
)
function EmployeeSpamCreateUntilServerThrottled(iterations);

Parameters

iterations Int32 (Optional)

Return Value

Task
See Also

Reference


CSharpPublicApiExampleProgram.EmployeeSpamCreateUntilServerThrottledLatest Method

CSharpPublicApiExampleProgramEmployeeSpamCreateUntilServerThrottledLatest Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task EmployeeSpamCreateUntilServerThrottledLatest(
    int iterations = 1
)
Public Function EmployeeSpamCreateUntilServerThrottledLatest (
    Optional iterations As Integer = 1
) As Task
public:
Task^ EmployeeSpamCreateUntilServerThrottledLatest(
    int iterations = 1
)
member EmployeeSpamCreateUntilServerThrottledLatest :
        ?iterations : int
(* Defaults:
        let _iterations = defaultArg iterations 1
*)
-> Task
public Task EmployeeSpamCreateUntilServerThrottledLatest(
    int iterations = 1
)
function EmployeeSpamCreateUntilServerThrottledLatest(iterations);

Parameters

iterations Int32 (Optional)

Return Value

Task
See Also

Reference


CSharpPublicApiExampleProgram.ExactSearchSite Method

CSharpPublicApiExampleProgramExactSearchSite Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private static Task ExactSearchSite(
    ApiSitesPublicApiClient siteClient
)
Private Shared Function ExactSearchSite (
    siteClient As ApiSitesPublicApiClient
) As Task
private:
static Task^ ExactSearchSite(
    ApiSitesPublicApiClient^ siteClient
)
private static member ExactSearchSite :
        siteClient : ApiSitesPublicApiClient -> Task
private static Task ExactSearchSite(
    ApiSitesPublicApiClient siteClient
)
Wasp.Cloud.Asset.Example.CSharpPublicApiExampleProgram.ExactSearchSite = function(siteClient);

Parameters

siteClient ApiSitesPublicApiClient

Return Value

Task
See Also

Reference


CSharpPublicApiExampleProgram.ExamplesThatRequireOnlyReadAccess Method

CSharpPublicApiExampleProgramExamplesThatRequireOnlyReadAccess Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task ExamplesThatRequireOnlyReadAccess(
    bool DemoDataExists
)
Public Function ExamplesThatRequireOnlyReadAccess (
    DemoDataExists As Boolean
) As Task
public:
Task^ ExamplesThatRequireOnlyReadAccess(
    bool DemoDataExists
)
member ExamplesThatRequireOnlyReadAccess :
        DemoDataExists : bool -> Task
public Task ExamplesThatRequireOnlyReadAccess(
    boolean DemoDataExists
)
function ExamplesThatRequireOnlyReadAccess(DemoDataExists);

Parameters

DemoDataExists Boolean

Return Value

Task
See Also

Reference


CSharpPublicApiExampleProgram.ExamplesThatRequireWriteAccess Method

CSharpPublicApiExampleProgramExamplesThatRequireWriteAccess Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task ExamplesThatRequireWriteAccess(
    bool DemoDataExists
)
Public Function ExamplesThatRequireWriteAccess (
    DemoDataExists As Boolean
) As Task
public:
Task^ ExamplesThatRequireWriteAccess(
    bool DemoDataExists
)
member ExamplesThatRequireWriteAccess :
        DemoDataExists : bool -> Task
public Task ExamplesThatRequireWriteAccess(
    boolean DemoDataExists
)
function ExamplesThatRequireWriteAccess(DemoDataExists);

Parameters

DemoDataExists Boolean

Return Value

Task
See Also

Reference


CSharpPublicApiExampleProgram.FetchAssetInfoWithExplicitAssetTags Method

CSharpPublicApiExampleProgramFetchAssetInfoWithExplicitAssetTags Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> FetchAssetInfoWithExplicitAssetTags(
    string[] assetTagsToFind
)
Private Function FetchAssetInfoWithExplicitAssetTags (
    assetTagsToFind As String()
) As Task(Of Integer)
private:
Task<int>^ FetchAssetInfoWithExplicitAssetTags(
    array<String^>^ assetTagsToFind
)
private member FetchAssetInfoWithExplicitAssetTags :
        assetTagsToFind : string[] -> Task<int>
private Task<int> FetchAssetInfoWithExplicitAssetTags(
    String[] assetTagsToFind
)
function FetchAssetInfoWithExplicitAssetTags(assetTagsToFind);

Parameters

assetTagsToFind String

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.FetchAssetInfoWithOwnerNumberFiltering Method

CSharpPublicApiExampleProgramFetchAssetInfoWithOwnerNumberFiltering Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> FetchAssetInfoWithOwnerNumberFiltering()
Private Function FetchAssetInfoWithOwnerNumberFiltering As Task(Of Integer)
private:
Task<int>^ FetchAssetInfoWithOwnerNumberFiltering()
private member FetchAssetInfoWithOwnerNumberFiltering : unit -> Task<int>
private Task<int> FetchAssetInfoWithOwnerNumberFiltering()
function FetchAssetInfoWithOwnerNumberFiltering();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.FetchTransactionHistoryInfoUsingGridQuery Method

CSharpPublicApiExampleProgramFetchTransactionHistoryInfoUsingGridQuery Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> FetchTransactionHistoryInfoUsingGridQuery()
Public Function FetchTransactionHistoryInfoUsingGridQuery As Task(Of Integer)
public:
Task<int>^ FetchTransactionHistoryInfoUsingGridQuery()
member FetchTransactionHistoryInfoUsingGridQuery : unit -> Task<int>
public Task<int> FetchTransactionHistoryInfoUsingGridQuery()
function FetchTransactionHistoryInfoUsingGridQuery();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.GenerateHelpExamples Method

CSharpPublicApiExampleProgramGenerateHelpExamples Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task GenerateHelpExamples()
Public Function GenerateHelpExamples As Task
public:
Task^ GenerateHelpExamples()
member GenerateHelpExamples : unit -> Task
public Task GenerateHelpExamples()
function GenerateHelpExamples();

Return Value

Task
See Also

Reference


CSharpPublicApiExampleProgram.GetCalloutHeaderPrivateKeyHash Method

CSharpPublicApiExampleProgramGetCalloutHeaderPrivateKeyHash Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string GetCalloutHeaderPrivateKeyHash(
    string Wasp_Callout_Name,
    string Wasp_Callout_Timestamp,
    string calloutPrivateKey
)
Public Function GetCalloutHeaderPrivateKeyHash (
    Wasp_Callout_Name As String,
    Wasp_Callout_Timestamp As String,
    calloutPrivateKey As String
) As String
public:
String^ GetCalloutHeaderPrivateKeyHash(
    String^ Wasp_Callout_Name,
    String^ Wasp_Callout_Timestamp,
    String^ calloutPrivateKey
)
member GetCalloutHeaderPrivateKeyHash :
        Wasp_Callout_Name : string *
        Wasp_Callout_Timestamp : string *
        calloutPrivateKey : string -> string
public String GetCalloutHeaderPrivateKeyHash(
    String Wasp_Callout_Name,
    String Wasp_Callout_Timestamp,
    String calloutPrivateKey
)
function GetCalloutHeaderPrivateKeyHash(Wasp_Callout_Name, Wasp_Callout_Timestamp, calloutPrivateKey);

Parameters

Wasp_Callout_Name String
Wasp_Callout_Timestamp String
calloutPrivateKey String

Return Value

String
See Also

Reference


CSharpPublicApiExampleProgram.GetDepartmentTests Method

CSharpPublicApiExampleProgramGetDepartmentTests Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task GetDepartmentTests()
Private Function GetDepartmentTests As Task
private:
Task^ GetDepartmentTests()
private member GetDepartmentTests : unit -> Task
private Task GetDepartmentTests()
function GetDepartmentTests();

Return Value

Task
See Also

Reference


CSharpPublicApiExampleProgram.GetEmployeeTests Method

CSharpPublicApiExampleProgramGetEmployeeTests Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task GetEmployeeTests()
Private Function GetEmployeeTests As Task
private:
Task^ GetEmployeeTests()
private member GetEmployeeTests : unit -> Task
private Task GetEmployeeTests()
function GetEmployeeTests();

Return Value

Task
See Also

Reference


CSharpPublicApiExampleProgram.GetServerInfo Method

CSharpPublicApiExampleProgramGetServerInfo Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<string> GetServerInfo()
Public Function GetServerInfo As Task(Of String)
public:
Task<String^>^ GetServerInfo()
member GetServerInfo : unit -> Task<string>
public Task<String> GetServerInfo()
function GetServerInfo();

Return Value

Task String
See Also

Reference


CSharpPublicApiExampleProgram.GetValue<T> Method

CSharpPublicApiExampleProgramGetValueT Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public T GetValue<T>(
    string[] values,
    int column
)

Public Function GetValue(Of T) (
    values As String(),
    column As Integer
) As T
public:
generic<typename T>
T GetValue(
    array<String^>^ values,
    int column
)
member GetValue :
        values : string[] *
        column : int -> 'T
J# supports the use of generic APIs, but not the declaration of new ones.
JavaScript does not support generic types or methods.

Parameters

values String
column Int32

Type Parameters

T

Return Value

T
See Also

Reference


CSharpPublicApiExampleProgram.ImportAttachmentsFromCSVFileToWaspApplication Method

CSharpPublicApiExampleProgramImportAttachmentsFromCSVFileToWaspApplication Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private void ImportAttachmentsFromCSVFileToWaspApplication(
    string formName,
    string csvFilePath,
    bool firstrow
)
Private Sub ImportAttachmentsFromCSVFileToWaspApplication (
    formName As String,
    csvFilePath As String,
    firstrow As Boolean
)
private:
void ImportAttachmentsFromCSVFileToWaspApplication(
    String^ formName,
    String^ csvFilePath,
    bool firstrow
)
private member ImportAttachmentsFromCSVFileToWaspApplication :
        formName : string *
        csvFilePath : string *
        firstrow : bool -> unit
private void ImportAttachmentsFromCSVFileToWaspApplication(
    String formName,
    String csvFilePath,
    boolean firstrow
)
function ImportAttachmentsFromCSVFileToWaspApplication(formName, csvFilePath, firstrow);

Parameters

formName String
csvFilePath String
firstrow Boolean
See Also

Reference


CSharpPublicApiExampleProgram.ImportAttachmentsFromLargeCSVFileToWaspApplication Method

CSharpPublicApiExampleProgramImportAttachmentsFromLargeCSVFileToWaspApplication Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private void ImportAttachmentsFromLargeCSVFileToWaspApplication(
    string formName,
    string csvFilePath,
    bool firstrow
)
Private Sub ImportAttachmentsFromLargeCSVFileToWaspApplication (
    formName As String,
    csvFilePath As String,
    firstrow As Boolean
)
private:
void ImportAttachmentsFromLargeCSVFileToWaspApplication(
    String^ formName,
    String^ csvFilePath,
    bool firstrow
)
private member ImportAttachmentsFromLargeCSVFileToWaspApplication :
        formName : string *
        csvFilePath : string *
        firstrow : bool -> unit
private void ImportAttachmentsFromLargeCSVFileToWaspApplication(
    String formName,
    String csvFilePath,
    boolean firstrow
)
function ImportAttachmentsFromLargeCSVFileToWaspApplication(formName, csvFilePath, firstrow);

Parameters

formName String
csvFilePath String
firstrow Boolean
See Also

Reference


CSharpPublicApiExampleProgram.Main Method

CSharpPublicApiExampleProgramMain Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private static int Main(
    string[] args
)
Private Shared Function Main (
    args As String()
) As Integer
private:
static int Main(
    array<String^>^ args
)
private static member Main :
        args : string[] -> int
private static int Main(
    String[] args
)
Wasp.Cloud.Asset.Example.CSharpPublicApiExampleProgram.Main = function(args);

Parameters

args String

Return Value

Int32
See Also

Reference


CSharpPublicApiExampleProgram.ManufacturersSample Method

CSharpPublicApiExampleProgramManufacturersSample Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> ManufacturersSample()
Private Function ManufacturersSample As Task(Of Integer)
private:
Task<int>^ ManufacturersSample()
private member ManufacturersSample : unit -> Task<int>
private Task<int> ManufacturersSample()
function ManufacturersSample();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.MassReadLine Method

CSharpPublicApiExampleProgramMassReadLine Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string MassReadLine(
    StreamReader stream,
    StringBuilder currentLine
)
Private Function MassReadLine (
    stream As StreamReader,
    currentLine As StringBuilder
) As String
private:
String^ MassReadLine(
    StreamReader^ stream,
    StringBuilder^ currentLine
)
private member MassReadLine :
        stream : StreamReader *
        currentLine : StringBuilder -> string
private String MassReadLine(
    StreamReader stream,
    StringBuilder currentLine
)
function MassReadLine(stream, currentLine);

Parameters

stream StreamReader
currentLine StringBuilder

Return Value

String
See Also

Reference


CSharpPublicApiExampleProgram.NewAssetType Method

CSharpPublicApiExampleProgramNewAssetType Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> NewAssetType()
Private Function NewAssetType As Task(Of Integer)
private:
Task<int>^ NewAssetType()
private member NewAssetType : unit -> Task<int>
private Task<int> NewAssetType()
function NewAssetType();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.ParseHex Method

CSharpPublicApiExampleProgramParseHex Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public byte[] ParseHex(
    string hex,
    string associatedTag
)
Public Function ParseHex (
    hex As String,
    associatedTag As String
) As Byte()
public:
array<unsigned char>^ ParseHex(
    String^ hex,
    String^ associatedTag
)
member ParseHex :
        hex : string *
        associatedTag : string -> byte[]
public byte[] ParseHex(
    String hex,
    String associatedTag
)
function ParseHex(hex, associatedTag);

Parameters

hex String
associatedTag String

Return Value

Byte
See Also

Reference


CSharpPublicApiExampleProgram.ParseNybble Method

CSharpPublicApiExampleProgramParseNybble Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private static int ParseNybble(
    char c
)
Private Shared Function ParseNybble (
    c As Char
) As Integer
private:
static int ParseNybble(
    wchar_t c
)
private static member ParseNybble :
        c : char -> int
private static int ParseNybble(
    char c
)
Wasp.Cloud.Asset.Example.CSharpPublicApiExampleProgram.ParseNybble = function(c);

Parameters

c Char

Return Value

Int32
See Also

Reference


CSharpPublicApiExampleProgram.RunAllExamples Method

CSharpPublicApiExampleProgramRunAllExamples Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task RunAllExamples()
Public Function RunAllExamples As Task
public:
Task^ RunAllExamples()
member RunAllExamples : unit -> Task
public Task RunAllExamples()
function RunAllExamples();

Return Value

Task
See Also

Reference


CSharpPublicApiExampleProgram.RunSitesLocationsDemo Method

CSharpPublicApiExampleProgramRunSitesLocationsDemo Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> RunSitesLocationsDemo()
Private Function RunSitesLocationsDemo As Task(Of Integer)
private:
Task<int>^ RunSitesLocationsDemo()
private member RunSitesLocationsDemo : unit -> Task<int>
private Task<int> RunSitesLocationsDemo()
function RunSitesLocationsDemo();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.SaveCustomerTest Method

CSharpPublicApiExampleProgramSaveCustomerTest Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task SaveCustomerTest()
Private Function SaveCustomerTest As Task
private:
Task^ SaveCustomerTest()
private member SaveCustomerTest : unit -> Task
private Task SaveCustomerTest()
function SaveCustomerTest();

Return Value

Task
See Also

Reference


CSharpPublicApiExampleProgram.SaveEmployeeTest Method

CSharpPublicApiExampleProgramSaveEmployeeTest Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task SaveEmployeeTest()
Private Function SaveEmployeeTest As Task
private:
Task^ SaveEmployeeTest()
private member SaveEmployeeTest : unit -> Task
private Task SaveEmployeeTest()
function SaveEmployeeTest();

Return Value

Task
See Also

Reference


CSharpPublicApiExampleProgram.SearchAsset Method

CSharpPublicApiExampleProgramSearchAsset Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> SearchAsset()
Public Function SearchAsset As Task(Of Integer)
public:
Task<int>^ SearchAsset()
member SearchAsset : unit -> Task<int>
public Task<int> SearchAsset()
function SearchAsset();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.SimpleCreateReadUpdateDeleteLocationSample Method

CSharpPublicApiExampleProgramSimpleCreateReadUpdateDeleteLocationSample Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> SimpleCreateReadUpdateDeleteLocationSample()
Private Function SimpleCreateReadUpdateDeleteLocationSample As Task(Of Integer)
private:
Task<int>^ SimpleCreateReadUpdateDeleteLocationSample()
private member SimpleCreateReadUpdateDeleteLocationSample : unit -> Task<int>
private Task<int> SimpleCreateReadUpdateDeleteLocationSample()
function SimpleCreateReadUpdateDeleteLocationSample();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.SimpleCreateReadUpdateDeleteSearchLocation Method

CSharpPublicApiExampleProgramSimpleCreateReadUpdateDeleteSearchLocation Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> SimpleCreateReadUpdateDeleteSearchLocation()
Public Function SimpleCreateReadUpdateDeleteSearchLocation As Task(Of Integer)
public:
Task<int>^ SimpleCreateReadUpdateDeleteSearchLocation()
member SimpleCreateReadUpdateDeleteSearchLocation : unit -> Task<int>
public Task<int> SimpleCreateReadUpdateDeleteSearchLocation()
function SimpleCreateReadUpdateDeleteSearchLocation();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.SimpleCreateReadUpdateDeleteSearchSite Method

CSharpPublicApiExampleProgramSimpleCreateReadUpdateDeleteSearchSite Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> SimpleCreateReadUpdateDeleteSearchSite()
Public Function SimpleCreateReadUpdateDeleteSearchSite As Task(Of Integer)
public:
Task<int>^ SimpleCreateReadUpdateDeleteSearchSite()
member SimpleCreateReadUpdateDeleteSearchSite : unit -> Task<int>
public Task<int> SimpleCreateReadUpdateDeleteSearchSite()
function SimpleCreateReadUpdateDeleteSearchSite();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.SimpleCreateReadUpdateDeleteSiteSample Method

CSharpPublicApiExampleProgramSimpleCreateReadUpdateDeleteSiteSample Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> SimpleCreateReadUpdateDeleteSiteSample()
Private Function SimpleCreateReadUpdateDeleteSiteSample As Task(Of Integer)
private:
Task<int>^ SimpleCreateReadUpdateDeleteSiteSample()
private member SimpleCreateReadUpdateDeleteSiteSample : unit -> Task<int>
private Task<int> SimpleCreateReadUpdateDeleteSiteSample()
function SimpleCreateReadUpdateDeleteSiteSample();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.SiteCustomFieldSample Method

CSharpPublicApiExampleProgramSiteCustomFieldSample Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> SiteCustomFieldSample()
Private Function SiteCustomFieldSample As Task(Of Integer)
private:
Task<int>^ SiteCustomFieldSample()
private member SiteCustomFieldSample : unit -> Task<int>
private Task<int> SiteCustomFieldSample()
function SiteCustomFieldSample();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.SiteModelInfoAdvancedSearch Method

CSharpPublicApiExampleProgramSiteModelInfoAdvancedSearch Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> SiteModelInfoAdvancedSearch()
Private Function SiteModelInfoAdvancedSearch As Task(Of Integer)
private:
Task<int>^ SiteModelInfoAdvancedSearch()
private member SiteModelInfoAdvancedSearch : unit -> Task<int>
private Task<int> SiteModelInfoAdvancedSearch()
function SiteModelInfoAdvancedSearch();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.SiteModelInfoAdvancedSearchAsRawJsonDataStrings Method

CSharpPublicApiExampleProgramSiteModelInfoAdvancedSearchAsRawJsonDataStrings Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> SiteModelInfoAdvancedSearchAsRawJsonDataStrings()
Private Function SiteModelInfoAdvancedSearchAsRawJsonDataStrings As Task(Of Integer)
private:
Task<int>^ SiteModelInfoAdvancedSearchAsRawJsonDataStrings()
private member SiteModelInfoAdvancedSearchAsRawJsonDataStrings : unit -> Task<int>
private Task<int> SiteModelInfoAdvancedSearchAsRawJsonDataStrings()
function SiteModelInfoAdvancedSearchAsRawJsonDataStrings();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.StreamInventoryAdvanced Method

CSharpPublicApiExampleProgramStreamInventoryAdvanced Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> StreamInventoryAdvanced()
Private Function StreamInventoryAdvanced As Task(Of Integer)
private:
Task<int>^ StreamInventoryAdvanced()
private member StreamInventoryAdvanced : unit -> Task<int>
private Task<int> StreamInventoryAdvanced()
function StreamInventoryAdvanced();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.SuppliersSample Method

CSharpPublicApiExampleProgramSuppliersSample Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> SuppliersSample()
Private Function SuppliersSample As Task(Of Integer)
private:
Task<int>^ SuppliersSample()
private member SuppliersSample : unit -> Task<int>
private Task<int> SuppliersSample()
function SuppliersSample();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.TransactionMove_GetHistoryNotesSample Method

CSharpPublicApiExampleProgramTransactionMove_GetHistoryNotesSample Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> TransactionMove_GetHistoryNotesSample()
Private Function TransactionMove_GetHistoryNotesSample As Task(Of Integer)
private:
Task<int>^ TransactionMove_GetHistoryNotesSample()
private member TransactionMove_GetHistoryNotesSample : unit -> Task<int>
private Task<int> TransactionMove_GetHistoryNotesSample()
function TransactionMove_GetHistoryNotesSample();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.UpdateAssetType Method

CSharpPublicApiExampleProgramUpdateAssetType Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> UpdateAssetType()
Private Function UpdateAssetType As Task(Of Integer)
private:
Task<int>^ UpdateAssetType()
private member UpdateAssetType : unit -> Task<int>
private Task<int> UpdateAssetType()
function UpdateAssetType();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.UpdateCustomersSample Method

CSharpPublicApiExampleProgramUpdateCustomersSample Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> UpdateCustomersSample()
Private Function UpdateCustomersSample As Task(Of Integer)
private:
Task<int>^ UpdateCustomersSample()
private member UpdateCustomersSample : unit -> Task<int>
private Task<int> UpdateCustomersSample()
function UpdateCustomersSample();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.UpdateManufacturersSample Method

CSharpPublicApiExampleProgramUpdateManufacturersSample Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> UpdateManufacturersSample()
Private Function UpdateManufacturersSample As Task(Of Integer)
private:
Task<int>^ UpdateManufacturersSample()
private member UpdateManufacturersSample : unit -> Task<int>
private Task<int> UpdateManufacturersSample()
function UpdateManufacturersSample();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.UpdatePurchaseOrderSample Method

CSharpPublicApiExampleProgramUpdatePurchaseOrderSample Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> UpdatePurchaseOrderSample()
Public Function UpdatePurchaseOrderSample As Task(Of Integer)
public:
Task<int>^ UpdatePurchaseOrderSample()
member UpdatePurchaseOrderSample : unit -> Task<int>
public Task<int> UpdatePurchaseOrderSample()
function UpdatePurchaseOrderSample();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.UpdateSuppliersSample Method

CSharpPublicApiExampleProgramUpdateSuppliersSample Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> UpdateSuppliersSample()
Private Function UpdateSuppliersSample As Task(Of Integer)
private:
Task<int>^ UpdateSuppliersSample()
private member UpdateSuppliersSample : unit -> Task<int>
private Task<int> UpdateSuppliersSample()
function UpdateSuppliersSample();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.UploadAttachmentForDifferentFormsSample Method

CSharpPublicApiExampleProgramUploadAttachmentForDifferentFormsSample Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> UploadAttachmentForDifferentFormsSample()
Private Function UploadAttachmentForDifferentFormsSample As Task(Of Integer)
private:
Task<int>^ UploadAttachmentForDifferentFormsSample()
private member UploadAttachmentForDifferentFormsSample : unit -> Task<int>
private Task<int> UploadAttachmentForDifferentFormsSample()
function UploadAttachmentForDifferentFormsSample();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.UploadAttachmentOnServer Method

CSharpPublicApiExampleProgramUploadAttachmentOnServer Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Task<int> UploadAttachmentOnServer()
Public Function UploadAttachmentOnServer As Task(Of Integer)
public:
Task<int>^ UploadAttachmentOnServer()
member UploadAttachmentOnServer : unit -> Task<int>
public Task<int> UploadAttachmentOnServer()
function UploadAttachmentOnServer();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.UploadAttachmentOnServerSample Method

CSharpPublicApiExampleProgramUploadAttachmentOnServerSample Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<int> UploadAttachmentOnServerSample()
Private Function UploadAttachmentOnServerSample As Task(Of Integer)
private:
Task<int>^ UploadAttachmentOnServerSample()
private member UploadAttachmentOnServerSample : unit -> Task<int>
private Task<int> UploadAttachmentOnServerSample()
function UploadAttachmentOnServerSample();

Return Value

Task Int32
See Also

Reference


CSharpPublicApiExampleProgram.UploadFile Method

CSharpPublicApiExampleProgramUploadFile Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task UploadFile(
    string urlString,
    string fileToUpload
)
Private Function UploadFile (
    urlString As String,
    fileToUpload As String
) As Task
private:
Task^ UploadFile(
    String^ urlString,
    String^ fileToUpload
)
private member UploadFile :
        urlString : string *
        fileToUpload : string -> Task
private Task UploadFile(
    String urlString,
    String fileToUpload
)
function UploadFile(urlString, fileToUpload);

Parameters

urlString String
fileToUpload String

Return Value

Task
See Also

Reference


CSharpPublicApiExampleProgram.UploadFileLatest Method

CSharpPublicApiExampleProgramUploadFileLatest Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private Task<List<string>> UploadFileLatest(
    string urlString,
    string fileToUpload
)
Private Function UploadFileLatest (
    urlString As String,
    fileToUpload As String
) As Task(Of List(Of String))
private:
Task<List<String^>^>^ UploadFileLatest(
    String^ urlString,
    String^ fileToUpload
)
private member UploadFileLatest :
        urlString : string *
        fileToUpload : string -> Task<List<string>>
private Task<List<String>> UploadFileLatest(
    String urlString,
    String fileToUpload
)
function UploadFileLatest(urlString, fileToUpload);

Parameters

urlString String
fileToUpload String

Return Value

Task List String
See Also

Reference


CSharpPublicApiExampleProgram Fields

The CSharpPublicApiExampleProgram type exposes the following members.

Fields
 | Name | Description
Private field | _guidString |
Private field | _initializer |
Private field | charBuffer |
 | DCF_SHIPMENT_NOT_RECEIVED |
 | DCF_SHIPMENT_SHIPPED |
Top
See Also

Reference


CSharpPublicApiExampleProgram._guidString Field

CSharpPublicApiExampleProgram_guidString Field

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _guidString
Private _guidString As String
private:
String^ _guidString
val mutable private _guidString: string
private String _guidString
var _guidString

Field Value

String
See Also

Reference


CSharpPublicApiExampleProgram._initializer Field

CSharpPublicApiExampleProgram_initializer Field

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private HttpClientInitializer _initializer
Private _initializer As HttpClientInitializer
private:
HttpClientInitializer^ _initializer
val mutable private _initializer: HttpClientInitializer
private HttpClientInitializer _initializer
var _initializer

Field Value

HttpClientInitializer
See Also

Reference


CSharpPublicApiExampleProgram.charBuffer Field

CSharpPublicApiExampleProgramcharBuffer Field

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private char[] charBuffer
Private charBuffer As Char()
private:
array<wchar_t>^ charBuffer
val mutable private charBuffer: char[]
private char[] charBuffer
var charBuffer

Field Value

Char
See Also

Reference


CSharpPublicApiExampleProgram.DCF_SHIPMENT_NOT_RECEIVED Field

CSharpPublicApiExampleProgramDCF_SHIPMENT_NOT_RECEIVED Field

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private const string DCF_SHIPMENT_NOT_RECEIVED = "Shipment not Received"
Private Const DCF_SHIPMENT_NOT_RECEIVED As String = "Shipment not Received"
private:
literal String^ DCF_SHIPMENT_NOT_RECEIVED = "Shipment not Received"
static val mutable private DCF_SHIPMENT_NOT_RECEIVED: string
private static final String DCF_SHIPMENT_NOT_RECEIVED
var Wasp.Cloud.Asset.Example.CSharpPublicApiExampleProgram.DCF_SHIPMENT_NOT_RECEIVED

Field Value

String
See Also

Reference


CSharpPublicApiExampleProgram.DCF_SHIPMENT_SHIPPED Field

CSharpPublicApiExampleProgramDCF_SHIPMENT_SHIPPED Field

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private const string DCF_SHIPMENT_SHIPPED = "Shipment Shipped"
Private Const DCF_SHIPMENT_SHIPPED As String = "Shipment Shipped"
private:
literal String^ DCF_SHIPMENT_SHIPPED = "Shipment Shipped"
static val mutable private DCF_SHIPMENT_SHIPPED: string
private static final String DCF_SHIPMENT_SHIPPED
var Wasp.Cloud.Asset.Example.CSharpPublicApiExampleProgram.DCF_SHIPMENT_SHIPPED

Field Value

String
See Also

Reference


CSharpPublicApiExampleProgram.AssetsPublicApiClientLongTimeout Class

CSharpPublicApiExampleProgramAssetsPublicApiClientLongTimeout Class

Inheritance Hierarchy
SystemObject
ExamplePublicApiClientBase
ApiAssetsPublicApiClient
Wasp.Cloud.Asset.ExampleCSharpPublicApiExampleProgramAssetsPublicApiClientLongTimeout

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public class AssetsPublicApiClientLongTimeout : ApiAssetsPublicApiClient
Public Class AssetsPublicApiClientLongTimeout
    Inherits ApiAssetsPublicApiClient
public ref class AssetsPublicApiClientLongTimeout : public ApiAssetsPublicApiClient
type AssetsPublicApiClientLongTimeout =
    class
        inherit ApiAssetsPublicApiClient
    end
public class AssetsPublicApiClientLongTimeout extends ApiAssetsPublicApiClient
Wasp.Cloud.Asset.Example.AssetsPublicApiClientLongTimeout = function();

Type.createClass(
    'Wasp.Cloud.Asset.Example.AssetsPublicApiClientLongTimeout',
    Wasp.Cloud.Asset.API.ApiAssetsPublicApiClient);

The CSharpPublicApiExampleProgramAssetsPublicApiClientLongTimeout type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpPublicApiExampleProgramAssetsPublicApiClientLongTimeout | Initializes a new instance of the CSharpPublicApiExampleProgramAssetsPublicApiClientLongTimeout class
Top
Properties
 | Name | Description
Public property | BaseUrl | (Inherited from ApiAssetsPublicApiClient)
Protected property | JsonSerializerSettings | (Inherited from ApiAssetsPublicApiClient)
Public property | ReadResponseAsString | (Inherited from ApiAssetsPublicApiClient)
Top
Methods
 | Name | Description
Public method | AddAssetQuantityAsync(IEnumerableAssetInfo) | This method is used to add quantity to the Multi-Quantity assets. Requires Add Asset Quantity permission. Accepts a maximum of 500 records at a time. (Inherited from ApiAssetsPublicApiClient)
Public method | AddAssetQuantityAsync(IEnumerableAssetInfo, CancellationToken) | This method is used to add quantity to the Multi-Quantity assets. Requires Add Asset Quantity permission. Accepts a maximum of 500 records at a time. (Inherited from ApiAssetsPublicApiClient)
Public method | AssetCheckOutStatusAsync(String) | This method returns check out information of the specified asset. Requires Allow Asset permission and enforces Role Site and Asset Type security. (Inherited from ApiAssetsPublicApiClient)
Public method | AssetCheckOutStatusAsync(String, CancellationToken) | This method returns check out information of the specified asset. Requires Allow Asset permission and enforces Role Site and Asset Type security. (Inherited from ApiAssetsPublicApiClient)
Public method | AssetInfoAdvancedSearchAsync(AdvancedSearchParameters) | This method returns a page full of active assets given a precise set of search, sort or filter criteria. It's a paging API so this is meant to be called with a smaller number (ca 100) or records to fetch, repeatedly, until you get them all. Requires Allow Asset permission and enforces Role Site and Asset Type security. Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. (Inherited from ApiAssetsPublicApiClient)
Public method | AssetInfoAdvancedSearchAsync(AdvancedSearchParameters, CancellationToken) | This method returns a page full of active assets given a precise set of search, sort or filter criteria. It's a paging API so this is meant to be called with a smaller number (ca 100) or records to fetch, repeatedly, until you get them all. Requires Allow Asset permission and enforces Role Site and Asset Type security. Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. (Inherited from ApiAssetsPublicApiClient)
Public method | AssetInfoSearchAsync(AssetContainsSearchParameters) | This method returns all active assets whose asset tag or asset description contains the specified texts that are entered on the combo box. This only returns asset level information, simulating the asset lookup controls in the web. Use public-api/assets/assetadvancedinfosearch to return those values. Requires Allow Asset permission and enforces Role Site and Asset Type security. Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. (Inherited from ApiAssetsPublicApiClient)
Public method | AssetInfoSearchAsync(AssetContainsSearchParameters, CancellationToken) | This method returns all active assets whose asset tag or asset description contains the specified texts that are entered on the combo box. This only returns asset level information, simulating the asset lookup controls in the web. Use public-api/assets/assetadvancedinfosearch to return those values. Requires Allow Asset permission and enforces Role Site and Asset Type security. Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. (Inherited from ApiAssetsPublicApiClient)
Public method | CreateFixedAssetsAsync(IEnumerableAssetInfo) | This method creates a new fixed asset. A fixed asset is unique across all sites and locations. The existing fixed asset is retrieved by calling API function GetAssetsByTags() or one of the searches. Requires Create Asset permission. Accepts a maximum of 500 records at a time. (Inherited from ApiAssetsPublicApiClient)
Public method | CreateFixedAssetsAsync(IEnumerableAssetInfo, CancellationToken) | This method creates a new fixed asset. A fixed asset is unique across all sites and locations. The existing fixed asset is retrieved by calling API function GetAssetsByTags() or one of the searches. Requires Create Asset permission. Accepts a maximum of 500 records at a time. (Inherited from ApiAssetsPublicApiClient)
Protected method | CreateHttpClientAsync | (Inherited from ExamplePublicApiClientBase)
Protected method | CreateHttpRequestMessageAsync | (Inherited from ExamplePublicApiClientBase)
Public method | CreateMultiQuantityAssetsAsync(IEnumerableInventoriedAssetInfo) | This method creates a new multi-quantity asset. A multi-quantity asset is not unique across sites and locations and may have quantity associated with it. The existing multi-quantity asset is retrieved by calling API function GetAssetsByTags() or one of the searches. Requires Create Asset permission. Accepts a maximum of 500 records at a time. (Inherited from ApiAssetsPublicApiClient)
Public method | CreateMultiQuantityAssetsAsync(IEnumerableInventoriedAssetInfo, CancellationToken) | This method creates a new multi-quantity asset. A multi-quantity asset is not unique across sites and locations and may have quantity associated with it. The existing multi-quantity asset is retrieved by calling API function GetAssetsByTags() or one of the searches. Requires Create Asset permission. Accepts a maximum of 500 records at a time. (Inherited from ApiAssetsPublicApiClient)
Public method | DecodeAsync``1 | (Inherited from ExamplePublicApiClientBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetAssetsByTagsAsync(IEnumerableString) | This method returns existing assets by asset tag. Does not return location information Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. Requires Allow Asset permission and enforces Role Site and Asset Type security. (Inherited from ApiAssetsPublicApiClient)
Public method | GetAssetsByTagsAsync(IEnumerableString, CancellationToken) | This method returns existing assets by asset tag. Does not return location information Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. Requires Allow Asset permission and enforces Role Site and Asset Type security. (Inherited from ApiAssetsPublicApiClient)
Public method | GetAssetsByTagsLightAsync(AssetSearchByAssetTags) | This method returns existing assets by asset tag. Does not return location information Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. Requires Allow Asset permission and enforces Role Site and Asset Type security. (Inherited from ApiAssetsPublicApiClient)
Public method | GetAssetsByTagsLightAsync(AssetSearchByAssetTags, CancellationToken) | This method returns existing assets by asset tag. Does not return location information Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. Requires Allow Asset permission and enforces Role Site and Asset Type security. (Inherited from ApiAssetsPublicApiClient)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | PartialUpdateFixedAssetAsync(IEnumerableInvariantCultureIgnoreCaseDictionary) | This method updates specific details of an existing fixed asset like updating the unique key asset tag/asset serial number. The existing fixed asset is retrieved by calling API function GetAssetsByTags() or one of the searches. Requires Edit Asset permission and enforces Role Site and Asset Type permission. Accepts a maximum of 500 records at a time. (Inherited from ApiAssetsPublicApiClient)
Public method | PartialUpdateFixedAssetAsync(IEnumerableInvariantCultureIgnoreCaseDictionary, CancellationToken) | This method updates specific details of an existing fixed asset like updating the unique key asset tag/asset serial number. The existing fixed asset is retrieved by calling API function GetAssetsByTags() or one of the searches. Requires Edit Asset permission and enforces Role Site and Asset Type permission. Accepts a maximum of 500 records at a time. (Inherited from ApiAssetsPublicApiClient)
Protected method | PrepareRequest(HttpClient, HttpRequestMessage, String) | (Inherited from ExamplePublicApiClientBase)
Protected method | PrepareRequest(HttpClient, HttpRequestMessage, StringBuilder) | (Overrides ExamplePublicApiClientBase.PrepareRequest(HttpClient, HttpRequestMessage, StringBuilder))
Protected method | ProcessResponse | (Inherited from ExamplePublicApiClientBase)
Protected method | ReadObjectResponseAsync``1 | (Inherited from ApiAssetsPublicApiClient)
Protected method | SaveJSONResponseToFile | (Inherited from ExamplePublicApiClientBase)
Public method | SaveLdapModelsByAssetSerialNumberAsync(IEnumerableInvariantCultureIgnoreCaseDictionary) | A public API created primary for use with our LDAP sync tool. This API takes a list of employees and will update and insert as necessary. Any employees not in the list, but active in the Cloud system will be deleted. Requires, Create, Edit, and Delete Employee permission (Inherited from ApiAssetsPublicApiClient)
Public method | SaveLdapModelsByAssetSerialNumberAsync(IEnumerableInvariantCultureIgnoreCaseDictionary, CancellationToken) | A public API created primary for use with our LDAP sync tool. This API takes a list of employees and will update and insert as necessary. Any employees not in the list, but active in the Cloud system will be deleted. Requires, Create, Edit, and Delete Employee permission (Inherited from ApiAssetsPublicApiClient)
Protected method | SaveRequestJSONBodyToFile | (Inherited from ExamplePublicApiClientBase)
Public method | StreamGridRequestCSVFlatAsync(GridStreamRequestModel) | Request asset inventory records as a stream of data in a CSV formated stream. If the FieldTitles parameter is null than all available fields are exported with default column titles. When you create Custom Fields on assets you can call this function with the FieldTitles parameter = null as well to see how custom fields look in the output stream. Important! Without this parameter the order and names of fields may change from version to version. Therefore, to ensure consisteny results from one version to the next, make sure you provide set this value after you have determined the values you need. (Inherited from ApiAssetsPublicApiClient)
Public method | StreamGridRequestCSVFlatAsync(GridStreamRequestModel, CancellationToken) | Request asset inventory records as a stream of data in a CSV formated stream. If the FieldTitles parameter is null than all available fields are exported with default column titles. When you create Custom Fields on assets you can call this function with the FieldTitles parameter = null as well to see how custom fields look in the output stream. Important! Without this parameter the order and names of fields may change from version to version. Therefore, to ensure consisteny results from one version to the next, make sure you provide set this value after you have determined the values you need. (Inherited from ApiAssetsPublicApiClient)
Public method | StreamGridRequestCSVUniqueAsync(GridStreamRequestModel) | Request asset records as a stream of data in a CSV formated stream. If the FieldTitles parameter is null than all available fields are exported with default column titles When you create Custom Fields on assets you can call this function with the FieldTitles parameter = null as well to see how custom fields look in the output stream. Important! Without this parameter the order and names of fields may change from version to version. Therefore, to ensure consisteny results from one version to the next, make sure you provide set this value after you have determined the values you need. Does not support paging as it is intended to stream all of the data at once (Inherited from ApiAssetsPublicApiClient)
Public method | StreamGridRequestCSVUniqueAsync(GridStreamRequestModel, CancellationToken) | Request asset records as a stream of data in a CSV formated stream. If the FieldTitles parameter is null than all available fields are exported with default column titles When you create Custom Fields on assets you can call this function with the FieldTitles parameter = null as well to see how custom fields look in the output stream. Important! Without this parameter the order and names of fields may change from version to version. Therefore, to ensure consisteny results from one version to the next, make sure you provide set this value after you have determined the values you need. Does not support paging as it is intended to stream all of the data at once (Inherited from ApiAssetsPublicApiClient)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UpdateFixedAssetsAsync(IEnumerableAssetInfo) | This method updates an existing fixed asset. The existing fixed asset is retrieved by calling API function GetAssetsByTags() or one of the searches. Requires Edit Asset permission. Accepts a maximum of 500 records at a time. (Inherited from ApiAssetsPublicApiClient)
Public method | UpdateFixedAssetsAsync(IEnumerableAssetInfo, CancellationToken) | This method updates an existing fixed asset. The existing fixed asset is retrieved by calling API function GetAssetsByTags() or one of the searches. Requires Edit Asset permission. Accepts a maximum of 500 records at a time. (Inherited from ApiAssetsPublicApiClient)
Protected method | UpdateJsonSerializerSettings | (Inherited from ExamplePublicApiClientBase)
Public method | UpdateMultiQuantityAssetsAsync(IEnumerableInventoriedAssetInfo) | This method updates an existing multi-quantity asset. The existing multi-quantity asset is retrieved by calling API function GetAssetsByTags() or one of the searches. Requires Create Asset permission. Accepts a maximum of 500 records at a time. (Inherited from ApiAssetsPublicApiClient)
Public method | UpdateMultiQuantityAssetsAsync(IEnumerableInventoriedAssetInfo, CancellationToken) | This method updates an existing multi-quantity asset. The existing multi-quantity asset is retrieved by calling API function GetAssetsByTags() or one of the searches. Requires Create Asset permission. Accepts a maximum of 500 records at a time. (Inherited from ApiAssetsPublicApiClient)
Top
Fields
 | Name | Description
Public field | RequestDescription | (Inherited from ExamplePublicApiClientBase)
Public field | SaveDirectory | (Inherited from ExamplePublicApiClientBase)
Top
See Also

Reference

Wasp.Cloud.Asset.Example Namespace


CSharpPublicApiExampleProgram.AssetsPublicApiClientLongTimeout Constructor

CSharpPublicApiExampleProgramAssetsPublicApiClientLongTimeout Constructor

Initializes a new instance of the CSharpPublicApiExampleProgramAssetsPublicApiClientLongTimeout class

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public AssetsPublicApiClientLongTimeout(
    string baseUrl
)
Public Sub New (
    baseUrl As String
)
public:
AssetsPublicApiClientLongTimeout(
    String^ baseUrl
)
new :
        baseUrl : string -> AssetsPublicApiClientLongTimeout
public AssetsPublicApiClientLongTimeout(
    String baseUrl
)
Wasp.Cloud.Asset.Example.AssetsPublicApiClientLongTimeout = function(baseUrl);

Parameters

baseUrl String
See Also

Reference

CSharpPublicApiExampleProgramAssetsPublicApiClientLongTimeout Class


AssetsPublicApiClientLongTimeout Properties

The CSharpPublicApiExampleProgramAssetsPublicApiClientLongTimeout type exposes the following members.

Properties
 | Name | Description
Public property | BaseUrl | (Inherited from ApiAssetsPublicApiClient)
Protected property | JsonSerializerSettings | (Inherited from ApiAssetsPublicApiClient)
Public property | ReadResponseAsString | (Inherited from ApiAssetsPublicApiClient)
Top
See Also

Reference

CSharpPublicApiExampleProgramAssetsPublicApiClientLongTimeout Class


AssetsPublicApiClientLongTimeout Methods

The CSharpPublicApiExampleProgramAssetsPublicApiClientLongTimeout type exposes the following members.

Methods
 | Name | Description
Public method | AddAssetQuantityAsync(IEnumerableAssetInfo) | This method is used to add quantity to the Multi-Quantity assets. Requires Add Asset Quantity permission. Accepts a maximum of 500 records at a time. (Inherited from ApiAssetsPublicApiClient)
Public method | AddAssetQuantityAsync(IEnumerableAssetInfo, CancellationToken) | This method is used to add quantity to the Multi-Quantity assets. Requires Add Asset Quantity permission. Accepts a maximum of 500 records at a time. (Inherited from ApiAssetsPublicApiClient)
Public method | AssetCheckOutStatusAsync(String) | This method returns check out information of the specified asset. Requires Allow Asset permission and enforces Role Site and Asset Type security. (Inherited from ApiAssetsPublicApiClient)
Public method | AssetCheckOutStatusAsync(String, CancellationToken) | This method returns check out information of the specified asset. Requires Allow Asset permission and enforces Role Site and Asset Type security. (Inherited from ApiAssetsPublicApiClient)
Public method | AssetInfoAdvancedSearchAsync(AdvancedSearchParameters) | This method returns a page full of active assets given a precise set of search, sort or filter criteria. It's a paging API so this is meant to be called with a smaller number (ca 100) or records to fetch, repeatedly, until you get them all. Requires Allow Asset permission and enforces Role Site and Asset Type security. Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. (Inherited from ApiAssetsPublicApiClient)
Public method | AssetInfoAdvancedSearchAsync(AdvancedSearchParameters, CancellationToken) | This method returns a page full of active assets given a precise set of search, sort or filter criteria. It's a paging API so this is meant to be called with a smaller number (ca 100) or records to fetch, repeatedly, until you get them all. Requires Allow Asset permission and enforces Role Site and Asset Type security. Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. (Inherited from ApiAssetsPublicApiClient)
Public method | AssetInfoSearchAsync(AssetContainsSearchParameters) | This method returns all active assets whose asset tag or asset description contains the specified texts that are entered on the combo box. This only returns asset level information, simulating the asset lookup controls in the web. Use public-api/assets/assetadvancedinfosearch to return those values. Requires Allow Asset permission and enforces Role Site and Asset Type security. Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. (Inherited from ApiAssetsPublicApiClient)
Public method | AssetInfoSearchAsync(AssetContainsSearchParameters, CancellationToken) | This method returns all active assets whose asset tag or asset description contains the specified texts that are entered on the combo box. This only returns asset level information, simulating the asset lookup controls in the web. Use public-api/assets/assetadvancedinfosearch to return those values. Requires Allow Asset permission and enforces Role Site and Asset Type security. Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. (Inherited from ApiAssetsPublicApiClient)
Public method | CreateFixedAssetsAsync(IEnumerableAssetInfo) | This method creates a new fixed asset. A fixed asset is unique across all sites and locations. The existing fixed asset is retrieved by calling API function GetAssetsByTags() or one of the searches. Requires Create Asset permission. Accepts a maximum of 500 records at a time. (Inherited from ApiAssetsPublicApiClient)
Public method | CreateFixedAssetsAsync(IEnumerableAssetInfo, CancellationToken) | This method creates a new fixed asset. A fixed asset is unique across all sites and locations. The existing fixed asset is retrieved by calling API function GetAssetsByTags() or one of the searches. Requires Create Asset permission. Accepts a maximum of 500 records at a time. (Inherited from ApiAssetsPublicApiClient)
Protected method | CreateHttpClientAsync | (Inherited from ExamplePublicApiClientBase)
Protected method | CreateHttpRequestMessageAsync | (Inherited from ExamplePublicApiClientBase)
Public method | CreateMultiQuantityAssetsAsync(IEnumerableInventoriedAssetInfo) | This method creates a new multi-quantity asset. A multi-quantity asset is not unique across sites and locations and may have quantity associated with it. The existing multi-quantity asset is retrieved by calling API function GetAssetsByTags() or one of the searches. Requires Create Asset permission. Accepts a maximum of 500 records at a time. (Inherited from ApiAssetsPublicApiClient)
Public method | CreateMultiQuantityAssetsAsync(IEnumerableInventoriedAssetInfo, CancellationToken) | This method creates a new multi-quantity asset. A multi-quantity asset is not unique across sites and locations and may have quantity associated with it. The existing multi-quantity asset is retrieved by calling API function GetAssetsByTags() or one of the searches. Requires Create Asset permission. Accepts a maximum of 500 records at a time. (Inherited from ApiAssetsPublicApiClient)
Public method | DecodeAsync``1 | (Inherited from ExamplePublicApiClientBase)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetAssetsByTagsAsync(IEnumerableString) | This method returns existing assets by asset tag. Does not return location information Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. Requires Allow Asset permission and enforces Role Site and Asset Type security. (Inherited from ApiAssetsPublicApiClient)
Public method | GetAssetsByTagsAsync(IEnumerableString, CancellationToken) | This method returns existing assets by asset tag. Does not return location information Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. Requires Allow Asset permission and enforces Role Site and Asset Type security. (Inherited from ApiAssetsPublicApiClient)
Public method | GetAssetsByTagsLightAsync(AssetSearchByAssetTags) | This method returns existing assets by asset tag. Does not return location information Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. Requires Allow Asset permission and enforces Role Site and Asset Type security. (Inherited from ApiAssetsPublicApiClient)
Public method | GetAssetsByTagsLightAsync(AssetSearchByAssetTags, CancellationToken) | This method returns existing assets by asset tag. Does not return location information Note: This is a Post API to avoid limitations inherent to passing parameters on the URL. Requires Allow Asset permission and enforces Role Site and Asset Type security. (Inherited from ApiAssetsPublicApiClient)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | PartialUpdateFixedAssetAsync(IEnumerableInvariantCultureIgnoreCaseDictionary) | This method updates specific details of an existing fixed asset like updating the unique key asset tag/asset serial number. The existing fixed asset is retrieved by calling API function GetAssetsByTags() or one of the searches. Requires Edit Asset permission and enforces Role Site and Asset Type permission. Accepts a maximum of 500 records at a time. (Inherited from ApiAssetsPublicApiClient)
Public method | PartialUpdateFixedAssetAsync(IEnumerableInvariantCultureIgnoreCaseDictionary, CancellationToken) | This method updates specific details of an existing fixed asset like updating the unique key asset tag/asset serial number. The existing fixed asset is retrieved by calling API function GetAssetsByTags() or one of the searches. Requires Edit Asset permission and enforces Role Site and Asset Type permission. Accepts a maximum of 500 records at a time. (Inherited from ApiAssetsPublicApiClient)
Protected method | PrepareRequest(HttpClient, HttpRequestMessage, String) | (Inherited from ExamplePublicApiClientBase)
Protected method | PrepareRequest(HttpClient, HttpRequestMessage, StringBuilder) | (Overrides ExamplePublicApiClientBase.PrepareRequest(HttpClient, HttpRequestMessage, StringBuilder))
Protected method | ProcessResponse | (Inherited from ExamplePublicApiClientBase)
Protected method | ReadObjectResponseAsync``1 | (Inherited from ApiAssetsPublicApiClient)
Protected method | SaveJSONResponseToFile | (Inherited from ExamplePublicApiClientBase)
Public method | SaveLdapModelsByAssetSerialNumberAsync(IEnumerableInvariantCultureIgnoreCaseDictionary) | A public API created primary for use with our LDAP sync tool. This API takes a list of employees and will update and insert as necessary. Any employees not in the list, but active in the Cloud system will be deleted. Requires, Create, Edit, and Delete Employee permission (Inherited from ApiAssetsPublicApiClient)
Public method | SaveLdapModelsByAssetSerialNumberAsync(IEnumerableInvariantCultureIgnoreCaseDictionary, CancellationToken) | A public API created primary for use with our LDAP sync tool. This API takes a list of employees and will update and insert as necessary. Any employees not in the list, but active in the Cloud system will be deleted. Requires, Create, Edit, and Delete Employee permission (Inherited from ApiAssetsPublicApiClient)
Protected method | SaveRequestJSONBodyToFile | (Inherited from ExamplePublicApiClientBase)
Public method | StreamGridRequestCSVFlatAsync(GridStreamRequestModel) | Request asset inventory records as a stream of data in a CSV formated stream. If the FieldTitles parameter is null than all available fields are exported with default column titles. When you create Custom Fields on assets you can call this function with the FieldTitles parameter = null as well to see how custom fields look in the output stream. Important! Without this parameter the order and names of fields may change from version to version. Therefore, to ensure consisteny results from one version to the next, make sure you provide set this value after you have determined the values you need. (Inherited from ApiAssetsPublicApiClient)
Public method | StreamGridRequestCSVFlatAsync(GridStreamRequestModel, CancellationToken) | Request asset inventory records as a stream of data in a CSV formated stream. If the FieldTitles parameter is null than all available fields are exported with default column titles. When you create Custom Fields on assets you can call this function with the FieldTitles parameter = null as well to see how custom fields look in the output stream. Important! Without this parameter the order and names of fields may change from version to version. Therefore, to ensure consisteny results from one version to the next, make sure you provide set this value after you have determined the values you need. (Inherited from ApiAssetsPublicApiClient)
Public method | StreamGridRequestCSVUniqueAsync(GridStreamRequestModel) | Request asset records as a stream of data in a CSV formated stream. If the FieldTitles parameter is null than all available fields are exported with default column titles When you create Custom Fields on assets you can call this function with the FieldTitles parameter = null as well to see how custom fields look in the output stream. Important! Without this parameter the order and names of fields may change from version to version. Therefore, to ensure consisteny results from one version to the next, make sure you provide set this value after you have determined the values you need. Does not support paging as it is intended to stream all of the data at once (Inherited from ApiAssetsPublicApiClient)
Public method | StreamGridRequestCSVUniqueAsync(GridStreamRequestModel, CancellationToken) | Request asset records as a stream of data in a CSV formated stream. If the FieldTitles parameter is null than all available fields are exported with default column titles When you create Custom Fields on assets you can call this function with the FieldTitles parameter = null as well to see how custom fields look in the output stream. Important! Without this parameter the order and names of fields may change from version to version. Therefore, to ensure consisteny results from one version to the next, make sure you provide set this value after you have determined the values you need. Does not support paging as it is intended to stream all of the data at once (Inherited from ApiAssetsPublicApiClient)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Public method | UpdateFixedAssetsAsync(IEnumerableAssetInfo) | This method updates an existing fixed asset. The existing fixed asset is retrieved by calling API function GetAssetsByTags() or one of the searches. Requires Edit Asset permission. Accepts a maximum of 500 records at a time. (Inherited from ApiAssetsPublicApiClient)
Public method | UpdateFixedAssetsAsync(IEnumerableAssetInfo, CancellationToken) | This method updates an existing fixed asset. The existing fixed asset is retrieved by calling API function GetAssetsByTags() or one of the searches. Requires Edit Asset permission. Accepts a maximum of 500 records at a time. (Inherited from ApiAssetsPublicApiClient)
Protected method | UpdateJsonSerializerSettings | (Inherited from ExamplePublicApiClientBase)
Public method | UpdateMultiQuantityAssetsAsync(IEnumerableInventoriedAssetInfo) | This method updates an existing multi-quantity asset. The existing multi-quantity asset is retrieved by calling API function GetAssetsByTags() or one of the searches. Requires Create Asset permission. Accepts a maximum of 500 records at a time. (Inherited from ApiAssetsPublicApiClient)
Public method | UpdateMultiQuantityAssetsAsync(IEnumerableInventoriedAssetInfo, CancellationToken) | This method updates an existing multi-quantity asset. The existing multi-quantity asset is retrieved by calling API function GetAssetsByTags() or one of the searches. Requires Create Asset permission. Accepts a maximum of 500 records at a time. (Inherited from ApiAssetsPublicApiClient)
Top
See Also

Reference

CSharpPublicApiExampleProgramAssetsPublicApiClientLongTimeout Class


CSharpPublicApiExampleProgram.AssetsPublicApiClientLongTimeout.PrepareRequest Method

CSharpPublicApiExampleProgramAssetsPublicApiClientLongTimeoutPrepareRequest Method

Overload List
 | Name | Description
Protected method | PrepareRequest(HttpClient, HttpRequestMessage, String) |
Protected method | PrepareRequest(HttpClient, HttpRequestMessage, StringBuilder) |
Top
See Also

Reference

CSharpPublicApiExampleProgramAssetsPublicApiClientLongTimeout Class


CSharpPublicApiExampleProgram.AssetsPublicApiClientLongTimeout.PrepareRequest(HttpClient, HttpRequestMessage, StringBuilder) Method

CSharpPublicApiExampleProgramAssetsPublicApiClientLongTimeoutPrepareRequest(HttpClient, HttpRequestMessage, StringBuilder) Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
protected override void PrepareRequest(
    HttpClient client,
    HttpRequestMessage request,
    StringBuilder urlBuilder
)
Protected Overrides Sub PrepareRequest (
    client As HttpClient,
    request As HttpRequestMessage,
    urlBuilder As StringBuilder
)
protected:
virtual void PrepareRequest(
    HttpClient^ client,
    HttpRequestMessage^ request,
    StringBuilder^ urlBuilder
) override
abstract PrepareRequest :
        client : HttpClient *
        request : HttpRequestMessage *
        urlBuilder : StringBuilder -> unit
override PrepareRequest :
        client : HttpClient *
        request : HttpRequestMessage *
        urlBuilder : StringBuilder -> unit
protected void PrepareRequest(
    HttpClient client,
    HttpRequestMessage request,
    StringBuilder urlBuilder
)
function PrepareRequest(client, request, urlBuilder);

Parameters

client HttpClient
request HttpRequestMessage
urlBuilder StringBuilder
See Also

Reference

CSharpPublicApiExampleProgramAssetsPublicApiClientLongTimeout Class
PrepareRequest Overload


AssetsPublicApiClientLongTimeout Fields

The CSharpPublicApiExampleProgramAssetsPublicApiClientLongTimeout type exposes the following members.

Fields
 | Name | Description
Public field | RequestDescription | (Inherited from ExamplePublicApiClientBase)
Public field | SaveDirectory | (Inherited from ExamplePublicApiClientBase)
Top
See Also

Reference

CSharpPublicApiExampleProgramAssetsPublicApiClientLongTimeout Class


CSharpPublicApiExampleProgram.AttachmentsUploadAssociatedModel Class

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class

Inheritance Hierarchy
SystemObject
Wasp.Cloud.Asset.ExampleCSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public class AttachmentsUploadAssociatedModel : INotifyPropertyChanged
Public Class AttachmentsUploadAssociatedModel
    Implements INotifyPropertyChanged
public ref class AttachmentsUploadAssociatedModel : INotifyPropertyChanged
type AttachmentsUploadAssociatedModel =
    class
        interface INotifyPropertyChanged
    end
public class AttachmentsUploadAssociatedModel implements INotifyPropertyChanged
Wasp.Cloud.Asset.Example.AttachmentsUploadAssociatedModel = function();

Type.createClass(
    'Wasp.Cloud.Asset.Example.AttachmentsUploadAssociatedModel',
    null,
    INotifyPropertyChanged);

The CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel | Initializes a new instance of the CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel class
Top
Properties
 | Name | Description
Public property | AssociatedObjectList |
Public property | AttachmentFormType |
Public property | AttachmentsList |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
 | FromJson |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Protected method | RaisePropertyChanged |
Public method | ToJson |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Fields
 | Name | Description
Private field | _associatedObjectList |
Private field | _attachmentFormType |
Private field | _attachmentsList |
Top
See Also

Reference

Wasp.Cloud.Asset.Example Namespace


CSharpPublicApiExampleProgram.AttachmentsUploadAssociatedModel Constructor

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Constructor

Initializes a new instance of the CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel class

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public AttachmentsUploadAssociatedModel()
Public Sub New
public:
AttachmentsUploadAssociatedModel()
new : unit -> AttachmentsUploadAssociatedModel
public AttachmentsUploadAssociatedModel()
Wasp.Cloud.Asset.Example.AttachmentsUploadAssociatedModel = function();
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


AttachmentsUploadAssociatedModel Properties

The CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel type exposes the following members.

Properties
 | Name | Description
Public property | AssociatedObjectList |
Public property | AttachmentFormType |
Public property | AttachmentsList |
Top
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


CSharpPublicApiExampleProgram.AttachmentsUploadAssociatedModel.AssociatedObjectList Property

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModelAssociatedObjectList Property

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public List<string> AssociatedObjectList { get; set; }
Public Property AssociatedObjectList As List(Of String)
    Get
    Set
public:
property List<String^>^ AssociatedObjectList {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
member AssociatedObjectList : List<string> with get, set
/** @property */
public List<String> get_AssociatedObjectList()
/** @property */
public void set_AssociatedObjectList(List<String> value)

function get_AssociatedObjectList();
function set_AssociatedObjectList(value);

Property Value

List String
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


CSharpPublicApiExampleProgram.AttachmentsUploadAssociatedModel.AttachmentFormType Property

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModelAttachmentFormType Property

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public CSharpPublicApiExampleProgramWtFormId AttachmentFormType { get; set; }
Public Property AttachmentFormType As CSharpPublicApiExampleProgramWtFormId
    Get
    Set
public:
property CSharpPublicApiExampleProgramWtFormId AttachmentFormType {
    CSharpPublicApiExampleProgramWtFormId get ();
    void set (CSharpPublicApiExampleProgramWtFormId value);
}
member AttachmentFormType : CSharpPublicApiExampleProgramWtFormId with get, set
/** @property */
public CSharpPublicApiExampleProgramWtFormId get_AttachmentFormType()
/** @property */
public void set_AttachmentFormType(CSharpPublicApiExampleProgramWtFormId value)

function get_AttachmentFormType();
function set_AttachmentFormType(value);

Property Value

CSharpPublicApiExampleProgramWtFormId
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


CSharpPublicApiExampleProgram.AttachmentsUploadAssociatedModel.AttachmentsList Property

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModelAttachmentsList Property

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public List<CSharpPublicApiExampleProgramAttachmentUploadAttributes> AttachmentsList { get; set; }
Public Property AttachmentsList As List(Of CSharpPublicApiExampleProgramAttachmentUploadAttributes)
    Get
    Set
public:
property List<CSharpPublicApiExampleProgramAttachmentUploadAttributes^>^ AttachmentsList {
    List<CSharpPublicApiExampleProgramAttachmentUploadAttributes^>^ get ();
    void set (List<CSharpPublicApiExampleProgramAttachmentUploadAttributes^>^ value);
}
member AttachmentsList : List<CSharpPublicApiExampleProgramAttachmentUploadAttributes> with get, set
/** @property */
public List<CSharpPublicApiExampleProgramAttachmentUploadAttributes> get_AttachmentsList()
/** @property */
public void set_AttachmentsList(List<CSharpPublicApiExampleProgramAttachmentUploadAttributes> value)

function get_AttachmentsList();
function set_AttachmentsList(value);

Property Value

List CSharpPublicApiExampleProgramAttachmentUploadAttributes
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


AttachmentsUploadAssociatedModel Methods

The CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
 | FromJson |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Protected method | RaisePropertyChanged |
Public method | ToJson |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


CSharpPublicApiExampleProgram.AttachmentsUploadAssociatedModel.FromJson Method

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModelFromJson Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel FromJson(
    string data
)
Public Shared Function FromJson (
    data As String
) As CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel
public:
static CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel^ FromJson(
    String^ data
)
static member FromJson :
        data : string -> CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel
public static CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel FromJson(
    String data
)
Wasp.Cloud.Asset.Example.AttachmentsUploadAssociatedModel.FromJson = function(data);

Parameters

data String

Return Value

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


CSharpPublicApiExampleProgram.AttachmentsUploadAssociatedModel.RaisePropertyChanged Method

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModelRaisePropertyChanged Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
protected virtual void RaisePropertyChanged(
    string propertyName = null
)
Protected Overridable Sub RaisePropertyChanged (
    Optional propertyName As String = Nothing
)
protected:
virtual void RaisePropertyChanged(
    String^ propertyName = nullptr
)
abstract RaisePropertyChanged :
        ?propertyName : string
(* Defaults:
        let _propertyName = defaultArg propertyName null
*)
-> unit
override RaisePropertyChanged :
        ?propertyName : string
(* Defaults:
        let _propertyName = defaultArg propertyName null
*)
-> unit
protected void RaisePropertyChanged(
    String propertyName = null
)
function RaisePropertyChanged(propertyName);

Parameters

propertyName String (Optional)
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


CSharpPublicApiExampleProgram.AttachmentsUploadAssociatedModel.ToJson Method

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModelToJson Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string ToJson()
Public Function ToJson As String
public:
String^ ToJson()
member ToJson : unit -> string
public String ToJson()
function ToJson();

Return Value

String
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


AttachmentsUploadAssociatedModel Events

The CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


CSharpPublicApiExampleProgram.AttachmentsUploadAssociatedModel.PropertyChanged Event

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModelPropertyChanged Event

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
/** @event */
public final void add_PropertyChanged (PropertyChangedEventHandler value)
/** @event */
public final void remove_PropertyChanged (PropertyChangedEventHandler value)

function add_PropertyChanged(value);
function remove_PropertyChanged(value);

Value

PropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


AttachmentsUploadAssociatedModel Fields

The CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel type exposes the following members.

Fields
 | Name | Description
Private field | _associatedObjectList |
Private field | _attachmentFormType |
Private field | _attachmentsList |
Top
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


CSharpPublicApiExampleProgram.AttachmentsUploadAssociatedModel._associatedObjectList Field

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel_associatedObjectList Field

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private List<string> _associatedObjectList
Private _associatedObjectList As List(Of String)
private:
List<String^>^ _associatedObjectList
val mutable private _associatedObjectList: List<string>
private List<String> _associatedObjectList
var _associatedObjectList

Field Value

List String
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


CSharpPublicApiExampleProgram.AttachmentsUploadAssociatedModel._attachmentFormType Field

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel_attachmentFormType Field

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private CSharpPublicApiExampleProgramWtFormId _attachmentFormType
Private _attachmentFormType As CSharpPublicApiExampleProgramWtFormId
private:
CSharpPublicApiExampleProgramWtFormId _attachmentFormType
val mutable private _attachmentFormType: CSharpPublicApiExampleProgramWtFormId
private CSharpPublicApiExampleProgramWtFormId _attachmentFormType
var _attachmentFormType

Field Value

CSharpPublicApiExampleProgramWtFormId
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


CSharpPublicApiExampleProgram.AttachmentsUploadAssociatedModel._attachmentsList Field

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel_attachmentsList Field

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private List<CSharpPublicApiExampleProgramAttachmentUploadAttributes> _attachmentsList
Private _attachmentsList As List(Of CSharpPublicApiExampleProgramAttachmentUploadAttributes)
private:
List<CSharpPublicApiExampleProgramAttachmentUploadAttributes^>^ _attachmentsList
val mutable private _attachmentsList: List<CSharpPublicApiExampleProgramAttachmentUploadAttributes>
private List<CSharpPublicApiExampleProgramAttachmentUploadAttributes> _attachmentsList
var _attachmentsList

Field Value

List CSharpPublicApiExampleProgramAttachmentUploadAttributes
See Also

Reference

CSharpPublicApiExampleProgramAttachmentsUploadAssociatedModel Class


CSharpPublicApiExampleProgram.AttachmentUploadAttributes Class

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class

Inheritance Hierarchy
SystemObject
Wasp.Cloud.Asset.ExampleCSharpPublicApiExampleProgramAttachmentUploadAttributes

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public class AttachmentUploadAttributes : INotifyPropertyChanged
Public Class AttachmentUploadAttributes
    Implements INotifyPropertyChanged
public ref class AttachmentUploadAttributes : INotifyPropertyChanged
type AttachmentUploadAttributes =
    class
        interface INotifyPropertyChanged
    end
public class AttachmentUploadAttributes implements INotifyPropertyChanged
Wasp.Cloud.Asset.Example.AttachmentUploadAttributes = function();

Type.createClass(
    'Wasp.Cloud.Asset.Example.AttachmentUploadAttributes',
    null,
    INotifyPropertyChanged);

The CSharpPublicApiExampleProgramAttachmentUploadAttributes type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpPublicApiExampleProgramAttachmentUploadAttributes | Initializes a new instance of the CSharpPublicApiExampleProgramAttachmentUploadAttributes class
Top
Properties
 | Name | Description
Public property | AttachmentFileByteArray |
Public property | AttachmentFileName |
Public property | AttachmentType |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
 | FromJson |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Protected method | RaisePropertyChanged |
Public method | ToJson |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Events
 | Name | Description
Public event | PropertyChanged |
Top
Fields
 | Name | Description
Private field | _attachmentFileByteArray |
Private field | _attachmentFileName |
Private field | _attachmentType |
Top
See Also

Reference

Wasp.Cloud.Asset.Example Namespace


CSharpPublicApiExampleProgram.AttachmentUploadAttributes Constructor

CSharpPublicApiExampleProgramAttachmentUploadAttributes Constructor

Initializes a new instance of the CSharpPublicApiExampleProgramAttachmentUploadAttributes class

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public AttachmentUploadAttributes()
Public Sub New
public:
AttachmentUploadAttributes()
new : unit -> AttachmentUploadAttributes
public AttachmentUploadAttributes()
Wasp.Cloud.Asset.Example.AttachmentUploadAttributes = function();
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


AttachmentUploadAttributes Properties

The CSharpPublicApiExampleProgramAttachmentUploadAttributes type exposes the following members.

Properties
 | Name | Description
Public property | AttachmentFileByteArray |
Public property | AttachmentFileName |
Public property | AttachmentType |
Top
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


CSharpPublicApiExampleProgram.AttachmentUploadAttributes.AttachmentFileByteArray Property

CSharpPublicApiExampleProgramAttachmentUploadAttributesAttachmentFileByteArray Property

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public byte[] AttachmentFileByteArray { get; set; }
Public Property AttachmentFileByteArray As Byte()
    Get
    Set
public:
property array<unsigned char>^ AttachmentFileByteArray {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member AttachmentFileByteArray : byte[] with get, set
/** @property */
public byte[] get_AttachmentFileByteArray()
/** @property */
public void set_AttachmentFileByteArray(byte[] value)

function get_AttachmentFileByteArray();
function set_AttachmentFileByteArray(value);

Property Value

Byte
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


CSharpPublicApiExampleProgram.AttachmentUploadAttributes.AttachmentFileName Property

CSharpPublicApiExampleProgramAttachmentUploadAttributesAttachmentFileName Property

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string AttachmentFileName { get; set; }
Public Property AttachmentFileName As String
    Get
    Set
public:
property String^ AttachmentFileName {
    String^ get ();
    void set (String^ value);
}
member AttachmentFileName : string with get, set
/** @property */
public String get_AttachmentFileName()
/** @property */
public void set_AttachmentFileName(String value)

function get_AttachmentFileName();
function set_AttachmentFileName(value);

Property Value

String
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


CSharpPublicApiExampleProgram.AttachmentUploadAttributes.AttachmentType Property

CSharpPublicApiExampleProgramAttachmentUploadAttributesAttachmentType Property

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public CSharpPublicApiExampleProgramUploadFileType AttachmentType { get; set; }
Public Property AttachmentType As CSharpPublicApiExampleProgramUploadFileType
    Get
    Set
public:
property CSharpPublicApiExampleProgramUploadFileType AttachmentType {
    CSharpPublicApiExampleProgramUploadFileType get ();
    void set (CSharpPublicApiExampleProgramUploadFileType value);
}
member AttachmentType : CSharpPublicApiExampleProgramUploadFileType with get, set
/** @property */
public CSharpPublicApiExampleProgramUploadFileType get_AttachmentType()
/** @property */
public void set_AttachmentType(CSharpPublicApiExampleProgramUploadFileType value)

function get_AttachmentType();
function set_AttachmentType(value);

Property Value

CSharpPublicApiExampleProgramUploadFileType
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


AttachmentUploadAttributes Methods

The CSharpPublicApiExampleProgramAttachmentUploadAttributes type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
 | FromJson |
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Protected method | RaisePropertyChanged |
Public method | ToJson |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


CSharpPublicApiExampleProgram.AttachmentUploadAttributes.FromJson Method

CSharpPublicApiExampleProgramAttachmentUploadAttributesFromJson Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static CSharpPublicApiExampleProgramAttachmentUploadAttributes FromJson(
    string data
)
Public Shared Function FromJson (
    data As String
) As CSharpPublicApiExampleProgramAttachmentUploadAttributes
public:
static CSharpPublicApiExampleProgramAttachmentUploadAttributes^ FromJson(
    String^ data
)
static member FromJson :
        data : string -> CSharpPublicApiExampleProgramAttachmentUploadAttributes
public static CSharpPublicApiExampleProgramAttachmentUploadAttributes FromJson(
    String data
)
Wasp.Cloud.Asset.Example.AttachmentUploadAttributes.FromJson = function(data);

Parameters

data String

Return Value

CSharpPublicApiExampleProgramAttachmentUploadAttributes
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


CSharpPublicApiExampleProgram.AttachmentUploadAttributes.RaisePropertyChanged Method

CSharpPublicApiExampleProgramAttachmentUploadAttributesRaisePropertyChanged Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
protected virtual void RaisePropertyChanged(
    string propertyName = null
)
Protected Overridable Sub RaisePropertyChanged (
    Optional propertyName As String = Nothing
)
protected:
virtual void RaisePropertyChanged(
    String^ propertyName = nullptr
)
abstract RaisePropertyChanged :
        ?propertyName : string
(* Defaults:
        let _propertyName = defaultArg propertyName null
*)
-> unit
override RaisePropertyChanged :
        ?propertyName : string
(* Defaults:
        let _propertyName = defaultArg propertyName null
*)
-> unit
protected void RaisePropertyChanged(
    String propertyName = null
)
function RaisePropertyChanged(propertyName);

Parameters

propertyName String (Optional)
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


CSharpPublicApiExampleProgram.AttachmentUploadAttributes.ToJson Method

CSharpPublicApiExampleProgramAttachmentUploadAttributesToJson Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public string ToJson()
Public Function ToJson As String
public:
String^ ToJson()
member ToJson : unit -> string
public String ToJson()
function ToJson();

Return Value

String
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


AttachmentUploadAttributes Events

The CSharpPublicApiExampleProgramAttachmentUploadAttributes type exposes the following members.

Events
 | Name | Description
Public event | PropertyChanged |
Top
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


CSharpPublicApiExampleProgram.AttachmentUploadAttributes.PropertyChanged Event

CSharpPublicApiExampleProgramAttachmentUploadAttributesPropertyChanged Event

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public event PropertyChangedEventHandler PropertyChanged
Public Event PropertyChanged As PropertyChangedEventHandler
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}
abstract PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
override PropertyChanged : IEvent<PropertyChangedEventHandler,
    PropertyChangedEventArgs>
/** @event */
public final void add_PropertyChanged (PropertyChangedEventHandler value)
/** @event */
public final void remove_PropertyChanged (PropertyChangedEventHandler value)

function add_PropertyChanged(value);
function remove_PropertyChanged(value);

Value

PropertyChangedEventHandler

Implements

INotifyPropertyChangedPropertyChanged
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


AttachmentUploadAttributes Fields

The CSharpPublicApiExampleProgramAttachmentUploadAttributes type exposes the following members.

Fields
 | Name | Description
Private field | _attachmentFileByteArray |
Private field | _attachmentFileName |
Private field | _attachmentType |
Top
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


CSharpPublicApiExampleProgram.AttachmentUploadAttributes._attachmentFileByteArray Field

CSharpPublicApiExampleProgramAttachmentUploadAttributes_attachmentFileByteArray Field

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private byte[] _attachmentFileByteArray
Private _attachmentFileByteArray As Byte()
private:
array<unsigned char>^ _attachmentFileByteArray
val mutable private _attachmentFileByteArray: byte[]
private byte[] _attachmentFileByteArray
var _attachmentFileByteArray

Field Value

Byte
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


CSharpPublicApiExampleProgram.AttachmentUploadAttributes._attachmentFileName Field

CSharpPublicApiExampleProgramAttachmentUploadAttributes_attachmentFileName Field

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private string _attachmentFileName
Private _attachmentFileName As String
private:
String^ _attachmentFileName
val mutable private _attachmentFileName: string
private String _attachmentFileName
var _attachmentFileName

Field Value

String
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


CSharpPublicApiExampleProgram.AttachmentUploadAttributes._attachmentType Field

CSharpPublicApiExampleProgramAttachmentUploadAttributes_attachmentType Field

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private CSharpPublicApiExampleProgramUploadFileType _attachmentType
Private _attachmentType As CSharpPublicApiExampleProgramUploadFileType
private:
CSharpPublicApiExampleProgramUploadFileType _attachmentType
val mutable private _attachmentType: CSharpPublicApiExampleProgramUploadFileType
private CSharpPublicApiExampleProgramUploadFileType _attachmentType
var _attachmentType

Field Value

CSharpPublicApiExampleProgramUploadFileType
See Also

Reference

CSharpPublicApiExampleProgramAttachmentUploadAttributes Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder Class

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class

Inheritance Hierarchy
SystemObject
Wasp.Cloud.Asset.ExampleCSharpPublicApiExampleProgramPurchaseOrderColumnOrder

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public class PurchaseOrderColumnOrder
Public Class PurchaseOrderColumnOrder
public ref class PurchaseOrderColumnOrder
type PurchaseOrderColumnOrder = class end
public class PurchaseOrderColumnOrder
Wasp.Cloud.Asset.Example.PurchaseOrderColumnOrder = function();

Type.createClass(
    'Wasp.Cloud.Asset.Example.PurchaseOrderColumnOrder');

The CSharpPublicApiExampleProgramPurchaseOrderColumnOrder type exposes the following members.

Constructors
 | Name | Description
Public method | CSharpPublicApiExampleProgramPurchaseOrderColumnOrder | Initializes a new instance of the CSharpPublicApiExampleProgramPurchaseOrderColumnOrder class
Top
Properties
 | Name | Description
Public property | DateDue |
Public property | DateStarted |
Public property | ItemNumber |
Public property | NoteText |
Public property | PayMethod |
Public property | PurchaseOrderNumber |
Public property | QuantityRequested |
Public property | ShipMethod |
Public property | ShipToAddressLine1 |
Public property | VendorAddressLine1 |
Public property | VendorNumber |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Fields
 | Name | Description
Private field | purchaseOrderColumnOrder |
Top
See Also

Reference

Wasp.Cloud.Asset.Example Namespace


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder Constructor

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Constructor

Initializes a new instance of the CSharpPublicApiExampleProgramPurchaseOrderColumnOrder class

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public PurchaseOrderColumnOrder()
Public Sub New
public:
PurchaseOrderColumnOrder()
new : unit -> PurchaseOrderColumnOrder
public PurchaseOrderColumnOrder()
Wasp.Cloud.Asset.Example.PurchaseOrderColumnOrder = function();
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


PurchaseOrderColumnOrder Properties

The CSharpPublicApiExampleProgramPurchaseOrderColumnOrder type exposes the following members.

Properties
 | Name | Description
Public property | DateDue |
Public property | DateStarted |
Public property | ItemNumber |
Public property | NoteText |
Public property | PayMethod |
Public property | PurchaseOrderNumber |
Public property | QuantityRequested |
Public property | ShipMethod |
Public property | ShipToAddressLine1 |
Public property | VendorAddressLine1 |
Public property | VendorNumber |
Top
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.DateDue Property

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderDateDue Property

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int DateDue { get; }
Public ReadOnly Property DateDue As Integer
    Get
public:
property int DateDue {
    int get ();
}
member DateDue : int with get
/** @property */
public int get_DateDue()

function get_DateDue();

Property Value

Int32
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.DateStarted Property

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderDateStarted Property

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int DateStarted { get; }
Public ReadOnly Property DateStarted As Integer
    Get
public:
property int DateStarted {
    int get ();
}
member DateStarted : int with get
/** @property */
public int get_DateStarted()

function get_DateStarted();

Property Value

Int32
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.ItemNumber Property

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderItemNumber Property

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int ItemNumber { get; }
Public ReadOnly Property ItemNumber As Integer
    Get
public:
property int ItemNumber {
    int get ();
}
member ItemNumber : int with get
/** @property */
public int get_ItemNumber()

function get_ItemNumber();

Property Value

Int32
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.NoteText Property

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderNoteText Property

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int NoteText { get; }
Public ReadOnly Property NoteText As Integer
    Get
public:
property int NoteText {
    int get ();
}
member NoteText : int with get
/** @property */
public int get_NoteText()

function get_NoteText();

Property Value

Int32
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.PayMethod Property

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderPayMethod Property

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int PayMethod { get; }
Public ReadOnly Property PayMethod As Integer
    Get
public:
property int PayMethod {
    int get ();
}
member PayMethod : int with get
/** @property */
public int get_PayMethod()

function get_PayMethod();

Property Value

Int32
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.PurchaseOrderNumber Property

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderPurchaseOrderNumber Property

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int PurchaseOrderNumber { get; }
Public ReadOnly Property PurchaseOrderNumber As Integer
    Get
public:
property int PurchaseOrderNumber {
    int get ();
}
member PurchaseOrderNumber : int with get
/** @property */
public int get_PurchaseOrderNumber()

function get_PurchaseOrderNumber();

Property Value

Int32
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.QuantityRequested Property

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderQuantityRequested Property

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int QuantityRequested { get; }
Public ReadOnly Property QuantityRequested As Integer
    Get
public:
property int QuantityRequested {
    int get ();
}
member QuantityRequested : int with get
/** @property */
public int get_QuantityRequested()

function get_QuantityRequested();

Property Value

Int32
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.ShipMethod Property

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderShipMethod Property

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int ShipMethod { get; }
Public ReadOnly Property ShipMethod As Integer
    Get
public:
property int ShipMethod {
    int get ();
}
member ShipMethod : int with get
/** @property */
public int get_ShipMethod()

function get_ShipMethod();

Property Value

Int32
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.ShipToAddressLine1 Property

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderShipToAddressLine1 Property

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int ShipToAddressLine1 { get; }
Public ReadOnly Property ShipToAddressLine1 As Integer
    Get
public:
property int ShipToAddressLine1 {
    int get ();
}
member ShipToAddressLine1 : int with get
/** @property */
public int get_ShipToAddressLine1()

function get_ShipToAddressLine1();

Property Value

Int32
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.VendorAddressLine1 Property

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderVendorAddressLine1 Property

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int VendorAddressLine1 { get; }
Public ReadOnly Property VendorAddressLine1 As Integer
    Get
public:
property int VendorAddressLine1 {
    int get ();
}
member VendorAddressLine1 : int with get
/** @property */
public int get_VendorAddressLine1()

function get_VendorAddressLine1();

Property Value

Int32
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.VendorNumber Property

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderVendorNumber Property

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public int VendorNumber { get; }
Public ReadOnly Property VendorNumber As Integer
    Get
public:
property int VendorNumber {
    int get ();
}
member VendorNumber : int with get
/** @property */
public int get_VendorNumber()

function get_VendorNumber();

Property Value

Int32
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


PurchaseOrderColumnOrder Methods

The CSharpPublicApiExampleProgramPurchaseOrderColumnOrder type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


PurchaseOrderColumnOrder Fields

The CSharpPublicApiExampleProgramPurchaseOrderColumnOrder type exposes the following members.

Fields
 | Name | Description
Private field | purchaseOrderColumnOrder |
Top
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.PurchaseOrderColumnOrder.purchaseOrderColumnOrder Field

CSharpPublicApiExampleProgramPurchaseOrderColumnOrderpurchaseOrderColumnOrder Field

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
private NameValueCollection purchaseOrderColumnOrder
Private purchaseOrderColumnOrder As NameValueCollection
private:
NameValueCollection^ purchaseOrderColumnOrder
val mutable private purchaseOrderColumnOrder: NameValueCollection
private NameValueCollection purchaseOrderColumnOrder
var purchaseOrderColumnOrder

Field Value

NameValueCollection
See Also

Reference

CSharpPublicApiExampleProgramPurchaseOrderColumnOrder Class


CSharpPublicApiExampleProgram.TConverter Class

CSharpPublicApiExampleProgramTConverter Class

Inheritance Hierarchy
SystemObject
Wasp.Cloud.Asset.ExampleCSharpPublicApiExampleProgramTConverter

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static class TConverter
Public NotInheritable Class TConverter
public ref class TConverter abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TConverter = class end
public final class TConverter
Wasp.Cloud.Asset.Example.TConverter = function();

Type.createClass(
    'Wasp.Cloud.Asset.Example.TConverter');

The CSharpPublicApiExampleProgramTConverter type exposes the following members.

Methods
Name | Description
ChangeType(Type, Object) |
ChangeTypeT(Object) |
RegisterTypeConverterT, TC |
Top
See Also

Reference

Wasp.Cloud.Asset.Example Namespace


TConverter Methods

The CSharpPublicApiExampleProgramTConverter type exposes the following members.

Methods
Name | Description
ChangeType(Type, Object) |
ChangeTypeT(Object) |
RegisterTypeConverterT, TC |
Top
See Also

Reference

CSharpPublicApiExampleProgramTConverter Class


CSharpPublicApiExampleProgram.TConverter.ChangeType Method

CSharpPublicApiExampleProgramTConverterChangeType Method

Overload List
Name | Description
ChangeType(Type, Object) |
ChangeTypeT(Object) |
Top
See Also

Reference

CSharpPublicApiExampleProgramTConverter Class


CSharpPublicApiExampleProgram.TConverter.ChangeType<T>(Object) Method

CSharpPublicApiExampleProgramTConverterChangeTypeT(Object) Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static T ChangeType<T>(
    Object value
)

Public Shared Function ChangeType(Of T) (
    value As Object
) As T
public:
generic<typename T>
static T ChangeType(
    Object^ value
)
static member ChangeType :
        value : Object -> 'T
J# supports the use of generic APIs, but not the declaration of new ones.
JavaScript does not support generic types or methods.

Parameters

value Object

Type Parameters

T

Return Value

T
See Also

Reference

CSharpPublicApiExampleProgramTConverter Class
ChangeType Overload


CSharpPublicApiExampleProgram.TConverter.ChangeType(Type, Object) Method

CSharpPublicApiExampleProgramTConverterChangeType(Type, Object) Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static Object ChangeType(
    Type t,
    Object value
)
Public Shared Function ChangeType (
    t As Type,
    value As Object
) As Object
public:
static Object^ ChangeType(
    Type^ t,
    Object^ value
)
static member ChangeType :
        t : Type *
        value : Object -> Object
public static Object ChangeType(
    Type t,
    Object value
)
Wasp.Cloud.Asset.Example.TConverter.ChangeType = function(t, value);

Parameters

t Type
value Object

Return Value

Object
See Also

Reference

CSharpPublicApiExampleProgramTConverter Class
ChangeType Overload


CSharpPublicApiExampleProgram.TConverter.RegisterTypeConverter<T, TC> Method

CSharpPublicApiExampleProgramTConverterRegisterTypeConverterT, TC Method

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static void RegisterTypeConverter<T, TC>()
where TC : TypeConverter

Public Shared Sub RegisterTypeConverter(Of T, TC As TypeConverter)
public:
generic<typename T, typename TC>
where TC : TypeConverter
static void RegisterTypeConverter()
static member RegisterTypeConverter : unit -> unit  when 'TC : TypeConverter
J# supports the use of generic APIs, but not the declaration of new ones.
JavaScript does not support generic types or methods.

Type Parameters

T
TC
See Also

Reference

CSharpPublicApiExampleProgramTConverter Class


CSharpPublicApiExampleProgram.UploadFileType Enumeration

CSharpPublicApiExampleProgramUploadFileType Enumeration

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public enum UploadFileType
Public Enumeration UploadFileType
public enum class UploadFileType
type UploadFileType
public enum UploadFileType
Wasp.Cloud.Asset.Example.UploadFileType = function();
Wasp.Cloud.Asset.Example.UploadFileType.createEnum('Wasp.Cloud.Asset.Example.UploadFileType', false);
Members
Member name | Value | Description
Unknown | 0 |
TextFile | 1 |
ImageFile | 2 |
SignatureFile | 3 |
See Also

Reference

Wasp.Cloud.Asset.Example Namespace


CSharpPublicApiExampleProgram.WtFormId Enumeration

CSharpPublicApiExampleProgramWtFormId Enumeration

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public enum WtFormId
Public Enumeration WtFormId
public enum class WtFormId
type WtFormId
public enum WtFormId
Wasp.Cloud.Asset.Example.WtFormId = function();
Wasp.Cloud.Asset.Example.WtFormId.createEnum('Wasp.Cloud.Asset.Example.WtFormId', false);
Members
Member name | Value | Description
Unknown | 0 |
Common | 100 |
CompanyInfo | 101 |
Customer | 104 |
Manufacturer | 105 |
Site | 107 |
Location | 108 |
Supplier | 109 |
Category | 110 |
Inventory | 111 |
Employee | 112 |
User | 113 |
CustomView | 114 |
Attachment | 115 |
Role | 116 |
Contract | 117 |
Department | 118 |
FormCustomization | 119 |
Condition | 120 |
DisposalReason | 121 |
RecoverReason | 122 |
WorkOrderType | 123 |
Asset | 200 |
AssetType | 201 |
AssetGroup | 202 |
AssetFunding | 203 |
AssetDCF | 204 |
AssetNotification | 205 |
DepreciationClass | 209 |
InventoriedAsset | 210 |
InventoriedAssetType | 211 |
AssetTransaction | 250 |
AssetAdd | 251 |
AssetDispose | 252 |
AssetMove | 253 |
AssetCheckIn | 254 |
AssetCheckOut | 255 |
AssetAudit | 256 |
AssetTransfer | 257 |
AssetMaintenance | 258 |
AssetDepreciation | 259 |
ApproveReservation | 260 |
CreateReservation | 261 |
AssetRecover | 262 |
AssetPurchaseDetail | 270 |
AssetConversion | 271 |
AssetMassUpdate | 272 |
AssetSetting | 273 |
AuditWindow | 274 |
AuditReconciliation | 275 |
MobileFilter | 276 |
MobileError | 277 |
Import | 278 |
TransHistory | 279 |
Task | 280 |
TaskType | 281 |
MaintenanceManagement | 282 |
WebLogin | 300 |
Reports | 306 |
AppOptions | 307 |
ReportSchedule | 308 |
MobileLogin | 400 |
Item | 1,100 |
InventoryItem | 1,101 |
NonInventoryItem | 1,102 |
KitItem | 1,103 |
AssemblyItem | 1,104 |
ContainerItem | 1,105 |
ServiceItem | 1,106 |
ItemPriceLevel | 1,130 |
ItemSupplier | 1,131 |
PricingTier | 1,132 |
ItemZone | 1,133 |
PurchaseOrder | 1,160 |
PickOrder | 1,161 |
Receive | 1,162 |
Ship | 1,163 |
UniversalOrder | 1,164 |
PurchaseOrderTotals | 1,165 |
Pick | 1,166 |
Build | 1,170 |
Disassemble | 1,171 |
ViewBuildOrder | 1,172 |
AutoBuild | 1,173 |
ICInventory | 1,249 |
InventoryTransactions | 1,250 |
InventoryAdd | 1,251 |
InventoryRemove | 1,252 |
InventoryMove | 1,253 |
InventoryCheckIn | 1,254 |
InventoryCheckOut | 1,255 |
InventoryAudit | 1,256 |
InventoryAdjust | 1,257 |
UnitOfMeasure | 1,258 |
GenerateLicenesePlateNumber | 1,259 |
BillOfMaterial | 1,260 |
WorkOrder | 1,261 |
WorkOrderHistory | 1,262 |
AssetWorkOrderLine | 1,263 |
PerformWorkForQuickMaintenance | 1,264 |
AssetLineWorkOrder | 1,265 |
PerformWorkForWorkOrder | 1,266 |
OrderStatusReasonCodeForWorkOrder | 1,267 |
PayMethod | 1,300 |
InventoryMobile | 1,400 |
AdjustReasonCode | 1,402 |
OrderSubtype | 1,405 |
MobileMain | 10,200 |
MobileNew | 10,201 |
MobileEdit | 10,202 |
MobileAudit | 10,203 |
MobileCheckin | 10,204 |
MobileCheckout | 10,205 |
MobileDispose | 10,206 |
MobileMove | 10,207 |
MobileMaintenance | 10,208 |
MobileAssetLookup | 10,209 |
MobileFundingAudit | 10,210 |
MobileLabelTemplates | 10,211 |
MobileNewInventoryAsset | 10,212 |
MobileReceive | 10,213 |
MobilePick | 10,214 |
MobileDetails | 10,215 |
MobileAdjust | 10,216 |
MobileAddInventory | 10,251 |
MobileRemoveInventory | 10,252 |
MobileAssetConversion | 10,271 |
TransactionHistoryGridConfiguration | 10,280 |
InternalHighOrderMultiplier | 100,000 |
ItemSite | 110,000,107 |
ItemLocation | 110,000,108 |
See Also

Reference

Wasp.Cloud.Asset.Example Namespace


Filter Class

Inheritance Hierarchy
SystemObject
FilterFlatModel
FilterModel
Wasp.Cloud.Asset.ExampleFilter

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public class Filter : FilterModel
Public Class Filter
    Inherits FilterModel
public ref class Filter : public FilterModel
type Filter =
    class
        inherit FilterModel
    end
public class Filter extends FilterModel
Wasp.Cloud.Asset.Example.Filter = function();

Type.createClass(
    'Wasp.Cloud.Asset.Example.Filter',
    Wasp.Cloud.Asset.API.FilterModel);

The Filter type exposes the following members.

Constructors
 | Name | Description
Public method | Filter | Initializes a new instance of the Filter class
Top
Properties
 | Name | Description
Public property | Field | Gets or sets the name of the sorted field (property). Set to null if the Filters property is set. (Inherited from FilterFlatModel)
Public property | Filters |
Public property | Operator | <![CDATA[ Gets or sets the filtering operator. Set to <c>null</c> if the <c>Filters</c> property is set. Possible values include: eq (==), neq (!=), lt (<), lte (<=), gt (>), gte (>=), startswith, endswith, contains, doesnotcontain Note that the operators startsWith, EndsWith, Contains, and DoesNotContain are for string/text fields only, and do NOT support any wild card characters. ]]> (Inherited from FilterFlatModel)
Public property | Value | Gets or sets the filtering value. Set to null if the Filters property is set. (Inherited from FilterFlatModel)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Operators
Name | Description
(Filter to TopLevelFilterType) |
Top
See Also

Reference

Wasp.Cloud.Asset.Example Namespace


Filter Constructor

Initializes a new instance of the Filter class

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public Filter()
Public Sub New
public:
Filter()
new : unit -> Filter
public Filter()
Wasp.Cloud.Asset.Example.Filter = function();
See Also

Reference

Filter Class


Filter Properties

The Filter type exposes the following members.

Properties
 | Name | Description
Public property | Field | Gets or sets the name of the sorted field (property). Set to null if the Filters property is set. (Inherited from FilterFlatModel)
Public property | Filters |
Public property | Operator | <![CDATA[ Gets or sets the filtering operator. Set to <c>null</c> if the <c>Filters</c> property is set. Possible values include: eq (==), neq (!=), lt (<), lte (<=), gt (>), gte (>=), startswith, endswith, contains, doesnotcontain Note that the operators startsWith, EndsWith, Contains, and DoesNotContain are for string/text fields only, and do NOT support any wild card characters. ]]> (Inherited from FilterFlatModel)
Public property | Value | Gets or sets the filtering value. Set to null if the Filters property is set. (Inherited from FilterFlatModel)
Top
See Also

Reference

Filter Class


Filter.Filters Property

FilterFilters Property

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public virtual List<Filter> Filters { get; set; }
Public Overridable Property Filters As List(Of Filter)
    Get
    Set
public:
virtual property List<Filter^>^ Filters {
    List<Filter^>^ get ();
    void set (List<Filter^>^ value);
}
abstract Filters : List<Filter> with get, set
override Filters : List<Filter> with get, set
/** @property */
public List<Filter> get_Filters()
/** @property */
public void set_Filters(List<Filter> value)

function get_Filters();
function set_Filters(value);

Property Value

List Filter
See Also

Reference

Filter Class


Filter Methods

The Filter type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
See Also

Reference

Filter Class


Filter Type Conversions

The Filter type exposes the following members.

Operators
Name | Description
(Filter to TopLevelFilterType) |
Top
See Also

Reference

Filter Class


Filter Implicit Conversion (Filter to TopLevelFilterType)

Filter Conversion (Filter to TopLevelFilterType)

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static implicit operator TopLevelFilterType (
    Filter filter
)
Public Shared Widening Operator CType (
    filter As Filter
) As TopLevelFilterType
static implicit operator TopLevelFilterType^ (
    Filter^ filter
)
F# does not support the declaration of new casting operators.
J# does not support overloaded operators.
JavaScript does not support the declaration of new casting operators.

Parameters

filter Filter

Return Value

TopLevelFilterType
See Also

Reference

Filter Class


SortCollection Class

Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection SortModel
SortCollection
Wasp.Cloud.Asset.ExampleSortCollection

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public class SortCollection : SortCollection
Public Class SortCollection
    Inherits SortCollection
public ref class SortCollection : public SortCollection
type SortCollection =
    class
        inherit SortCollection
    end
public class SortCollection extends SortCollection
Wasp.Cloud.Asset.Example.SortCollection = function();

Type.createClass(
    'Wasp.Cloud.Asset.Example.SortCollection',
    Wasp.Cloud.Asset.API.SortCollection);

The SortCollection type exposes the following members.

Constructors
 | Name | Description
Public method | SortCollection | Initializes a new instance of the SortCollection class
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection SortModel)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection SortModel)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection SortModel)
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection SortModel)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection SortModel)
Protected method | ClearItems | Removes all elements from the CollectionT. (Inherited from Collection SortModel)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection SortModel)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection SortModel)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection SortModel)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection SortModel)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection SortModel)
Protected method | InsertItem | Inserts an element into the CollectionT at the specified index. (Inherited from Collection SortModel)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection SortModel)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection SortModel)
Protected method | RemoveItem | Removes the element at the specified index of the CollectionT. (Inherited from Collection SortModel)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection SortModel)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Operators
Name | Description
(ListSort to SortCollection) |
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IListAdd | Adds an item to the IList. (Inherited from Collection SortModel)
Explicit interface implementation | IListContains | Determines whether the IList contains a specific value. (Inherited from Collection SortModel)
Explicit interface implementation | ICollectionCopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection SortModel)
Explicit interface implementation | IEnumerableGetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection SortModel)
Explicit interface implementation | IListIndexOf | Determines the index of a specific item in the IList. (Inherited from Collection SortModel)
Explicit interface implementation | IListInsert | Inserts an item into the IList at the specified index. (Inherited from Collection SortModel)
Explicit interface implementation | IListIsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection SortModel)
Explicit interface implementation | ICollectionTIsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from Collection SortModel)
Explicit interface implementation | IListIsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection SortModel)
Explicit interface implementation | ICollectionIsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection SortModel)
Explicit interface implementation | IListItem | Gets or sets the element at the specified index. (Inherited from Collection SortModel)
Explicit interface implementation | IListRemove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection SortModel)
Explicit interface implementation | ICollectionSyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection SortModel)
Top
See Also

Reference

Wasp.Cloud.Asset.Example Namespace


SortCollection Constructor

Initializes a new instance of the SortCollection class

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public SortCollection()
Public Sub New
public:
SortCollection()
new : unit -> SortCollection
public SortCollection()
Wasp.Cloud.Asset.Example.SortCollection = function();
See Also

Reference

SortCollection Class


SortCollection Properties

The SortCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection SortModel)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection SortModel)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection SortModel)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IListIsFixedSize | Gets a value indicating whether the IList has a fixed size. (Inherited from Collection SortModel)
Explicit interface implementation | ICollectionTIsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from Collection SortModel)
Explicit interface implementation | IListIsReadOnly | Gets a value indicating whether the IList is read-only. (Inherited from Collection SortModel)
Explicit interface implementation | ICollectionIsSynchronized | Gets a value indicating whether access to the ICollection is synchronized (thread safe). (Inherited from Collection SortModel)
Explicit interface implementation | IListItem | Gets or sets the element at the specified index. (Inherited from Collection SortModel)
Explicit interface implementation | ICollectionSyncRoot | Gets an object that can be used to synchronize access to the ICollection. (Inherited from Collection SortModel)
Top
See Also

Reference

SortCollection Class


SortCollection Methods

The SortCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection SortModel)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection SortModel)
Protected method | ClearItems | Removes all elements from the CollectionT. (Inherited from Collection SortModel)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection SortModel)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection SortModel)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection SortModel)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection SortModel)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection SortModel)
Protected method | InsertItem | Inserts an element into the CollectionT at the specified index. (Inherited from Collection SortModel)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection SortModel)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection SortModel)
Protected method | RemoveItem | Removes the element at the specified index of the CollectionT. (Inherited from Collection SortModel)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection SortModel)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IListAdd | Adds an item to the IList. (Inherited from Collection SortModel)
Explicit interface implementation | IListContains | Determines whether the IList contains a specific value. (Inherited from Collection SortModel)
Explicit interface implementation | ICollectionCopyTo | Copies the elements of the ICollection to an Array, starting at a particular Array index. (Inherited from Collection SortModel)
Explicit interface implementation | IEnumerableGetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from Collection SortModel)
Explicit interface implementation | IListIndexOf | Determines the index of a specific item in the IList. (Inherited from Collection SortModel)
Explicit interface implementation | IListInsert | Inserts an item into the IList at the specified index. (Inherited from Collection SortModel)
Explicit interface implementation | IListRemove | Removes the first occurrence of a specific object from the IList. (Inherited from Collection SortModel)
Top
See Also

Reference

SortCollection Class


SortCollection Type Conversions

The SortCollection type exposes the following members.

Operators
Name | Description
(ListSort to SortCollection) |
Top
See Also

Reference

SortCollection Class


SortCollection Implicit Conversion (List<Sort> to SortCollection)

SortCollection Conversion (ListSort to SortCollection)

Namespace: Wasp.Cloud.Asset.Example
Assembly: Wasp.MobileAsset.PublicApiExample (in Wasp.MobileAsset.PublicApiExample.exe) Version: 1.0.0.0 (1.0.0.0)
Syntax
C#
VB
C++
F#
J#
JavaScript
Copy
public static implicit operator SortCollection (
    List<Sort> sorts
)
Public Shared Widening Operator CType (
    sorts As List(Of Sort)
) As SortCollection
static implicit operator SortCollection^ (
    List<Sort^>^ sorts
)
F# does not support the declaration of new casting operators.
J# does not support overloaded operators.
JavaScript does not support the declaration of new casting operators.

Parameters

sorts List Sort

Return Value

SortCollection
See Also

Reference

SortCollection Class